Add preferences UI for Facebook. Tidy up lose ends related to this;
[hermes] / package / debian / hermes.postinst
1 #!/bin/sh
2
3 set -e
4 gconftool-2 -s /apps/maemo/hermes/facebook_app 5916f12942feea4b3247d42a84371112 --type string
5 gconftool-2 -s /apps/maemo/hermes/facebook_secret 19f7538edd96b6870f2da7e84a6390a4 --type string
6 gconftool-2 -s /apps/maemo/hermes/gravatar_email TODO --type string
7 gconftool-2 -s /apps/maemo/hermes/gravatar_key TODO --type string
8
9
10 # Version 0.2.1 changed type of /apps/maemo/hermes/uid
11 OLD_UID=`gconftool-2 -g /apps/maemo/hermes/uid`
12 [ -z "$OLD_UID" ] || gconftool-2 -s /apps/maemo/hermes/uid "$OLD_UID" --type string
13
14 # Hacky fix for NB#136012
15 gconftool-2 -s /desktop/gnome/url-handlers/http/command 'dbus-send --system --type=method_call --dest="com.nokia.osso_browser" --print-reply /com/nokia/osso_browser/request com.nokia.osso_browser.load_url string:"%s"' --type string 
16
17 gtk-update-icon-cache -f /usr/share/icons/hicolor