0.2.1: fixes Facebook UIDs > MAX_INT, reported by atilla
[hermes] / package / debian / hermes.postinst
1 #!/bin/sh
2
3 set -e
4 gconftool-2 -s /apps/maemo/hermes/key_app 5916f12942feea4b3247d42a84371112 --type string
5 gconftool-2 -s /apps/maemo/hermes/key_secret 19f7538edd96b6870f2da7e84a6390a4 --type string
6
7 # Version 0.2.1 changed type of /apps/maemo/hermes/uid
8 OLD_UID=`gconftool-2 -g /apps/maemo/hermes/uid`
9 [ -z "$OLD_UID" ] || gconftool-2 -s /apps/maemo/hermes/uid "$OLD_UID" --type string
10
11 # Hacky fix for NB#136012
12 gconftool-2 -s /desktop/gnome/url-handlers/http/command 'dbus-send --system --type=method_call --dest="com.nokia.osso_browser" --print-reply /com/nokia/osso_browser/request com.nokia.osso_browser.load_url string:"%s"' --type string 
13
14 gtk-update-icon-cache -f /usr/share/icons/hicolor