Add the original source packages to maemo, source lenny
[dh-make-perl] / dev / i386 / libmodule-build-perl / libmodule-build-perl-0.2808.01 / debian / patches / man-ext
1 Fix manual page extensions for Debian.
2
3 --- libmodule-build-perl.orig/lib/Module/Build/Base.pm
4 +++ libmodule-build-perl/lib/Module/Build/Base.pm
5 @@ -2552,7 +2552,7 @@
6    foreach my $file (keys %$files) {
7      # Pod::Simple based parsers only support one document per instance.
8      # This is expected to change in a future version (Pod::Simple > 3.03).
9 -    my $parser  = Pod::Man->new( section => 1 ); # binaries go in section 1
10 +    my $parser  = Pod::Man->new( section => '1p' ); # binaries go in section 1
11      my $manpage = $self->man1page_name( $file ) . '.' .
12                   $self->config( 'man1ext' );
13      my $outfile = File::Spec->catfile($mandir, $manpage);
14 @@ -2576,7 +2576,7 @@
15    while (my ($file, $relfile) = each %$files) {
16      # Pod::Simple based parsers only support one document per instance.
17      # This is expected to change in a future version (Pod::Simple > 3.03).
18 -    my $parser  = Pod::Man->new( section => 3 ); # libraries go in section 3
19 +    my $parser  = Pod::Man->new( section => '3pm' ); # libraries go in section 3
20      my $manpage = $self->man3page_name( $relfile ) . '.' .
21                   $self->config( 'man3ext' );
22      my $outfile = File::Spec->catfile( $mandir, $manpage);