Add ARM files
[dh-make-perl] / dev / arm / libclass-accessor-perl / libclass-accessor-perl-0.31 / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 include /usr/share/quilt/quilt.make
9
10 # Define the perl interpreter
11
12 PERL = /usr/bin/perl
13
14 PACKAGE = $(shell dh_listpackages)
15
16 TMP = $(CURDIR)/debian/$(PACKAGE)
17
18 configure: configure-stamp
19 configure-stamp:
20         dh_testdir
21
22         perl Makefile.PL verbose INSTALLDIRS=vendor
23
24         touch configure-stamp
25
26
27 build: patch build-stamp
28 build-stamp: configure-stamp 
29         dh_testdir
30
31         $(MAKE)
32         $(MAKE) test
33         touch build-stamp
34
35 clean: unpatch
36         dh_testdir
37         dh_testroot
38
39         [ ! -e Makefile ] || $(MAKE) distclean
40
41         dh_clean build-stamp configure-stamp
42
43 install: build
44         dh_testdir
45         dh_testroot
46         dh_clean -k
47         dh_installdirs
48
49         $(MAKE) install PREFIX=$(TMP)/usr
50
51         # Remove any empty directories
52
53         find $(TMP)/usr -type d -empty -print0 | xargs --null --no-run-if-empty rmdir -p --ignore-fail-on-non-empty
54
55 # Build architecture-independent files here.
56 binary-arch: build install
57 # We have nothing to do by default.
58
59 # Build architecture-dependent files here.
60 binary-indep: build install
61         dh_testdir
62         dh_testroot
63         dh_perl
64         dh_installdocs README
65         dh_installman
66         dh_installchangelogs Changes
67         dh_installexamples examples/*
68         dh_compress
69         dh_fixperms
70         dh_installdeb
71         dh_gencontrol
72         dh_md5sums
73         dh_builddeb
74
75 binary: binary-indep binary-arch
76 .PHONY: build clean binary-indep binary-arch binary install configure