Contents of /branches/ports/maemo/src/Makefile

Parent Directory Parent Directory | Revision Log Revision Log


Revision 5 - (hide annotations)
Wed Dec 10 20:11:09 2008 UTC (15 years, 6 months ago) by harbaum
Original Path: trunk/src/Makefile
File size: 9500 byte(s)
Fixed version.h generation
1 harbaum 1 #
2     # Copyright (C) 2008 Till Harbaum <till@harbaum.org>.
3     #
4     # This file is part of OSM2Go.
5     #
6     # OSM2Go is free software: you can redistribute it and/or modify
7     # it under the terms of the GNU General Public License as published by
8     # the Free Software Foundation, either version 3 of the License, or
9     # (at your option) any later version.
10     #
11     # OSM2Go is distributed in the hope that it will be useful,
12     # but WITHOUT ANY WARRANTY; without even the implied warranty of
13     # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14     # GNU General Public License for more details.
15     #
16     # You should have received a copy of the GNU General Public License
17     # along with OSM2Go. If not, see <http://www.gnu.org/licenses/>.
18     #
19    
20     APP = osm2go
21     PREFIX = /usr/local
22    
23     PKGS = gtk+-2.0 libxml-2.0 goocanvas libcurl gthread-2.0 \
24     gnome-vfs-module-2.0
25    
26     OBJS = main.o map.o osm.o osm_api.o wms.o \
27     statusbar.o project.o settings.o pos.o diff.o map_hl.o \
28     iconbar.o info.o icon.o track.o gps.o canvas_goocanvas.o \
29     area_edit.o josm_presets.o relation_edit.o misc.o map_edit.o \
30 harbaum 4 josm_elemstyles.o style.o net_io.o
31 harbaum 1
32     DEFS = -DPACKAGE=\"$(APP)\" -DUSE_GOOCANVAS
33     CFLAGS = -Wall -O2 $(DEFS) `pkg-config --cflags $(PKGS)`
34     LDFLAGS = `pkg-config --libs $(PKGS)`
35    
36     all: $(APP)
37    
38     version.h: ../debian/changelog
39     awk '!/^$$/ { print "#define VERSION \"" $$2 "\"";exit }' $< | tr -d \(\) > $@
40    
41     %.o: %.c
42     gcc $(CFLAGS) -o $@ -c $<
43    
44     $(APP): $(OBJS)
45     gcc $(LDFLAGS) -o $@ $(OBJS)
46    
47     clean:
48     rm -f osm2go *.o *~ */*~ \#*\# version.h *.bak
49    
50 harbaum 5 dep: version.h
51 harbaum 1 makedepend -Y *.c
52    
53     # DO NOT DELETE
54    
55 harbaum 5 area_edit.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
56     area_edit.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
57     area_edit.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
58     area_edit.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
59     area_edit.o: net_io.h
60     canvas_gnomecanvas.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
61     canvas_gnomecanvas.o: osm_api.h project.h statusbar.h area_edit.h settings.h
62     canvas_gnomecanvas.o: diff.h iconbar.h icon.h info.h track.h gps.h wms.h
63 harbaum 1 canvas_gnomecanvas.o: josm_presets.h relation_edit.h misc.h map_edit.h
64 harbaum 4 canvas_gnomecanvas.o: josm_elemstyles.h style.h net_io.h
65 harbaum 5 canvas_goocanvas.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
66     canvas_goocanvas.o: osm_api.h project.h statusbar.h area_edit.h settings.h
67     canvas_goocanvas.o: diff.h iconbar.h icon.h info.h track.h gps.h wms.h
68 harbaum 1 canvas_goocanvas.o: josm_presets.h relation_edit.h misc.h map_edit.h
69 harbaum 4 canvas_goocanvas.o: josm_elemstyles.h style.h net_io.h
70 harbaum 5 dbus.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
71     dbus.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
72     dbus.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
73     dbus.o: map_edit.h josm_elemstyles.h style.h net_io.h
74     diff.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
75     diff.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
76     diff.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
77     diff.o: map_edit.h josm_elemstyles.h style.h net_io.h
78     gps.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
79     gps.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
80     gps.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
81     gps.o: map_edit.h josm_elemstyles.h style.h net_io.h
82     icon.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
83     icon.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
84     icon.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
85     icon.o: map_edit.h josm_elemstyles.h style.h net_io.h
86     iconbar.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
87     iconbar.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
88     iconbar.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
89     iconbar.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
90     info.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
91     info.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
92     info.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
93     info.o: map_edit.h josm_elemstyles.h style.h net_io.h
94     josm_elemstyles.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
95     josm_elemstyles.o: osm_api.h project.h statusbar.h area_edit.h settings.h
96     josm_elemstyles.o: diff.h iconbar.h icon.h info.h track.h gps.h wms.h
97     josm_elemstyles.o: josm_presets.h relation_edit.h misc.h map_edit.h
98     josm_elemstyles.o: josm_elemstyles.h style.h net_io.h
99     josm_presets.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
100     josm_presets.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
101     josm_presets.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
102 harbaum 1 josm_presets.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
103 harbaum 4 josm_presets.o: net_io.h
104 harbaum 5 main.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
105     main.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
106     main.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
107     main.o: map_edit.h josm_elemstyles.h style.h net_io.h
108     map.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
109     map.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
110     map.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
111     map.o: map_edit.h josm_elemstyles.h style.h net_io.h
112     map_edit.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
113     map_edit.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
114     map_edit.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
115     map_edit.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
116     map_hl.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
117     map_hl.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
118     map_hl.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
119     map_hl.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
120     misc.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
121     misc.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
122     misc.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
123     misc.o: map_edit.h josm_elemstyles.h style.h net_io.h
124     net_io.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
125     net_io.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
126     net_io.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
127     net_io.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
128     osm.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
129     osm.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
130     osm.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
131     osm.o: map_edit.h josm_elemstyles.h style.h net_io.h
132     osm_api.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
133     osm_api.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
134     osm_api.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
135     osm_api.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
136     pos.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
137     pos.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
138     pos.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
139     pos.o: map_edit.h josm_elemstyles.h style.h net_io.h
140     project.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
141     project.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
142     project.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
143     project.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
144     relation_edit.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
145     relation_edit.o: osm_api.h project.h statusbar.h area_edit.h settings.h
146     relation_edit.o: diff.h iconbar.h icon.h info.h track.h gps.h wms.h
147     relation_edit.o: josm_presets.h relation_edit.h misc.h map_edit.h
148     relation_edit.o: josm_elemstyles.h style.h net_io.h
149     settings.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
150     settings.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
151     settings.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
152     settings.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
153     statusbar.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
154     statusbar.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
155     statusbar.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
156     statusbar.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
157     statusbar.o: net_io.h
158     style.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
159     style.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
160     style.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
161     style.o: map_edit.h josm_elemstyles.h style.h net_io.h
162     track.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
163     track.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
164     track.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
165     track.o: map_edit.h josm_elemstyles.h style.h net_io.h
166     wms.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
167     wms.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
168     wms.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
169     wms.o: map_edit.h josm_elemstyles.h style.h net_io.h