Contents of /branches/ports/maemo/src/Makefile

Parent Directory Parent Directory | Revision Log Revision Log


Revision 28 - (hide annotations)
Wed Dec 24 14:17:20 2008 UTC (15 years, 4 months ago) by achadwick
Original Path: trunk/src/Makefile
File size: 9841 byte(s)
The "look at me still talking when there's mapping to do" update.

UI: Make display more responsive during long busy periods. Use Hildon banners
    if available, or temporary statusbar messages for non-Hildon. Some message
    wording changes.

Bugfix: Prevent some segfaults when tapping screen during a redraw by putting
    a grabby banner in the way.

Etc: Update credits.
1 harbaum 1 #
2     # Copyright (C) 2008 Till Harbaum <till@harbaum.org>.
3     #
4     # This file is part of OSM2Go.
5     #
6     # OSM2Go is free software: you can redistribute it and/or modify
7     # it under the terms of the GNU General Public License as published by
8     # the Free Software Foundation, either version 3 of the License, or
9     # (at your option) any later version.
10     #
11     # OSM2Go is distributed in the hope that it will be useful,
12     # but WITHOUT ANY WARRANTY; without even the implied warranty of
13     # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14     # GNU General Public License for more details.
15     #
16     # You should have received a copy of the GNU General Public License
17     # along with OSM2Go. If not, see <http://www.gnu.org/licenses/>.
18     #
19    
20     APP = osm2go
21     PREFIX = /usr/local
22    
23     PKGS = gtk+-2.0 libxml-2.0 goocanvas libcurl gthread-2.0 \
24     gnome-vfs-module-2.0
25    
26     OBJS = main.o map.o osm.o osm_api.o wms.o \
27     statusbar.o project.o settings.o pos.o diff.o map_hl.o \
28     iconbar.o info.o icon.o track.o gps.o canvas_goocanvas.o \
29     area_edit.o josm_presets.o relation_edit.o misc.o map_edit.o \
30 achadwick 28 josm_elemstyles.o style.o net_io.o banner.o
31 harbaum 1
32     DEFS = -DPACKAGE=\"$(APP)\" -DUSE_GOOCANVAS
33     CFLAGS = -Wall -O2 $(DEFS) `pkg-config --cflags $(PKGS)`
34     LDFLAGS = `pkg-config --libs $(PKGS)`
35    
36     all: $(APP)
37    
38     version.h: ../debian/changelog
39     awk '!/^$$/ { print "#define VERSION \"" $$2 "\"";exit }' $< | tr -d \(\) > $@
40    
41     %.o: %.c
42     gcc $(CFLAGS) -o $@ -c $<
43    
44     $(APP): $(OBJS)
45     gcc $(LDFLAGS) -o $@ $(OBJS)
46    
47     clean:
48     rm -f osm2go *.o *~ */*~ \#*\# version.h *.bak
49    
50 harbaum 5 dep: version.h
51 harbaum 1 makedepend -Y *.c
52    
53     # DO NOT DELETE
54    
55 harbaum 5 area_edit.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
56     area_edit.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
57     area_edit.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
58     area_edit.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
59     area_edit.o: net_io.h
60 achadwick 28 banner.o: banner.h appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
61     banner.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
62     banner.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
63     banner.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
64     banner.o: net_io.h
65 harbaum 5 canvas_gnomecanvas.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
66     canvas_gnomecanvas.o: osm_api.h project.h statusbar.h area_edit.h settings.h
67     canvas_gnomecanvas.o: diff.h iconbar.h icon.h info.h track.h gps.h wms.h
68 harbaum 1 canvas_gnomecanvas.o: josm_presets.h relation_edit.h misc.h map_edit.h
69 harbaum 4 canvas_gnomecanvas.o: josm_elemstyles.h style.h net_io.h
70 harbaum 5 canvas_goocanvas.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
71     canvas_goocanvas.o: osm_api.h project.h statusbar.h area_edit.h settings.h
72     canvas_goocanvas.o: diff.h iconbar.h icon.h info.h track.h gps.h wms.h
73 harbaum 1 canvas_goocanvas.o: josm_presets.h relation_edit.h misc.h map_edit.h
74 harbaum 4 canvas_goocanvas.o: josm_elemstyles.h style.h net_io.h
75 harbaum 5 dbus.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
76     dbus.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
77     dbus.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
78     dbus.o: map_edit.h josm_elemstyles.h style.h net_io.h
79     diff.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
80     diff.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
81     diff.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
82     diff.o: map_edit.h josm_elemstyles.h style.h net_io.h
83     gps.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
84     gps.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
85     gps.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
86     gps.o: map_edit.h josm_elemstyles.h style.h net_io.h
87     icon.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
88     icon.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
89     icon.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
90     icon.o: map_edit.h josm_elemstyles.h style.h net_io.h
91     iconbar.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
92     iconbar.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
93     iconbar.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
94     iconbar.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
95     info.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
96     info.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
97     info.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
98     info.o: map_edit.h josm_elemstyles.h style.h net_io.h
99     josm_elemstyles.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
100     josm_elemstyles.o: osm_api.h project.h statusbar.h area_edit.h settings.h
101     josm_elemstyles.o: diff.h iconbar.h icon.h info.h track.h gps.h wms.h
102     josm_elemstyles.o: josm_presets.h relation_edit.h misc.h map_edit.h
103     josm_elemstyles.o: josm_elemstyles.h style.h net_io.h
104     josm_presets.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
105     josm_presets.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
106     josm_presets.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
107 harbaum 1 josm_presets.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
108 harbaum 4 josm_presets.o: net_io.h
109 harbaum 5 main.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
110     main.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
111     main.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
112 achadwick 28 main.o: map_edit.h josm_elemstyles.h style.h net_io.h banner.h
113 harbaum 5 map.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
114     map.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
115     map.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
116     map.o: map_edit.h josm_elemstyles.h style.h net_io.h
117     map_edit.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
118     map_edit.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
119     map_edit.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
120     map_edit.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
121     map_hl.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
122     map_hl.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
123     map_hl.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
124     map_hl.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
125     misc.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
126     misc.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
127     misc.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
128     misc.o: map_edit.h josm_elemstyles.h style.h net_io.h
129     net_io.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
130     net_io.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
131     net_io.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
132     net_io.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
133     osm.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
134     osm.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
135     osm.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
136 achadwick 28 osm.o: map_edit.h josm_elemstyles.h style.h net_io.h banner.h
137 harbaum 5 osm_api.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
138     osm_api.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
139     osm_api.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
140     osm_api.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
141     pos.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
142     pos.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
143     pos.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
144     pos.o: map_edit.h josm_elemstyles.h style.h net_io.h
145     project.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
146     project.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
147     project.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
148 achadwick 28 project.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h banner.h
149 harbaum 5 relation_edit.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
150     relation_edit.o: osm_api.h project.h statusbar.h area_edit.h settings.h
151     relation_edit.o: diff.h iconbar.h icon.h info.h track.h gps.h wms.h
152     relation_edit.o: josm_presets.h relation_edit.h misc.h map_edit.h
153     relation_edit.o: josm_elemstyles.h style.h net_io.h
154     settings.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
155     settings.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h
156     settings.o: icon.h info.h track.h gps.h wms.h josm_presets.h relation_edit.h
157     settings.o: misc.h map_edit.h josm_elemstyles.h style.h net_io.h
158     statusbar.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h
159     statusbar.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
160     statusbar.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
161     statusbar.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
162     statusbar.o: net_io.h
163     style.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
164     style.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
165     style.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
166     style.o: map_edit.h josm_elemstyles.h style.h net_io.h
167     track.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
168     track.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
169     track.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
170     track.o: map_edit.h josm_elemstyles.h style.h net_io.h
171     wms.o: appdata.h version.h pos.h osm.h canvas.h map.h map_hl.h osm_api.h
172     wms.o: project.h statusbar.h area_edit.h settings.h diff.h iconbar.h icon.h
173     wms.o: info.h track.h gps.h wms.h josm_presets.h relation_edit.h misc.h
174     wms.o: map_edit.h josm_elemstyles.h style.h net_io.h