Contents of /branches/ports/maemo/src/Makefile.in

Parent Directory Parent Directory | Revision Log Revision Log


Revision 137 - (hide annotations)
Sat Mar 21 22:37:16 2009 UTC (15 years, 2 months ago) by achadwick
File size: 10435 byte(s)
Merge to tags/trunk-0.6.14 (-r89:HEAD). Will commit build fixes separately.
1 harbaum 110 #
2     # Copyright (C) 2008 Till Harbaum <till@harbaum.org>.
3     #
4     # This file is part of OSM2Go.
5     #
6     # OSM2Go is free software: you can redistribute it and/or modify
7     # it under the terms of the GNU General Public License as published by
8     # the Free Software Foundation, either version 3 of the License, or
9     # (at your option) any later version.
10     #
11     # OSM2Go is distributed in the hope that it will be useful,
12     # but WITHOUT ANY WARRANTY; without even the implied warranty of
13     # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14     # GNU General Public License for more details.
15     #
16     # You should have received a copy of the GNU General Public License
17     # along with OSM2Go. If not, see <http://www.gnu.org/licenses/>.
18     #
19    
20     APP = @PACKAGE@
21     PREFIX ?= @prefix@
22     EXTRA_OBJS = @EXTRA_OBJS@
23 achadwick 129 VERSION = $${VERSION_PREFIX}@PACKAGE_VERSION@$${VERSION_SUFFIX}
24 harbaum 110
25 achadwick 129 bindir = @bindir@
26    
27    
28 harbaum 110 OBJS = main.o map.o osm.o osm_api.o wms.o \
29     statusbar.o project.o settings.o pos.o diff.o map_hl.o \
30     iconbar.o info.o icon.o track.o gps.o canvas_goocanvas.o \
31     area_edit.o josm_presets.o relation_edit.o misc.o map_edit.o \
32     josm_elemstyles.o style.o net_io.o banner.o undo.o $(EXTRA_OBJS)
33    
34 achadwick 129 DEFS = -DPACKAGE=\"$(APP)\" -DPREFIX=\"@prefix@\" -DVERSION=\"$(VERSION)\"
35 harbaum 110 CFLAGS = -Wall $(DEFS) @CFLAGS@
36     LDFLAGS = @LIBS@
37    
38     all: $(APP)
39    
40     %.o: %.c
41     gcc $(CFLAGS) -o $@ -c $<
42    
43     $(APP): $(OBJS)
44     gcc $(LDFLAGS) -o $@ $(OBJS)
45    
46     clean:
47     rm -f osm2go *.o *~ */*~ \#*\# version.h *.bak
48    
49     install: $(APP)
50 achadwick 129 install -d $(DESTDIR)$(PREFIX)$(bindir)
51     install $(APP) $(DESTDIR)$(PREFIX)$(bindir)
52 harbaum 110
53     # DO NOT DELETE
54    
55 achadwick 129 area_edit.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
56 harbaum 110 area_edit.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
57     area_edit.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
58     area_edit.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
59     area_edit.o: net_io.h banner.h
60 achadwick 129 banner.o: banner.h appdata.h pos.h osm.h canvas.h undo.h map.h
61 harbaum 110 banner.o: map_hl.h osm_api.h project.h statusbar.h area_edit.h settings.h
62     banner.o: diff.h iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
63     banner.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
64     banner.o: net_io.h
65 achadwick 129 canvas_gnomecanvas.o: appdata.h pos.h osm.h canvas.h undo.h map.h
66 harbaum 110 canvas_gnomecanvas.o: map_hl.h osm_api.h project.h statusbar.h area_edit.h
67     canvas_gnomecanvas.o: settings.h diff.h iconbar.h icon.h info.h track.h gps.h
68     canvas_gnomecanvas.o: wms.h josm_presets.h relation_edit.h misc.h map_edit.h
69     canvas_gnomecanvas.o: josm_elemstyles.h style.h net_io.h banner.h
70 achadwick 129 canvas_goocanvas.o: appdata.h pos.h osm.h canvas.h undo.h map.h
71 harbaum 110 canvas_goocanvas.o: map_hl.h osm_api.h project.h statusbar.h area_edit.h
72     canvas_goocanvas.o: settings.h diff.h iconbar.h icon.h info.h track.h gps.h
73     canvas_goocanvas.o: wms.h josm_presets.h relation_edit.h misc.h map_edit.h
74     canvas_goocanvas.o: josm_elemstyles.h style.h net_io.h banner.h
75 achadwick 129 dbus.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
76 harbaum 110 dbus.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
77     dbus.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
78     dbus.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
79     dbus.o: banner.h
80 achadwick 129 diff.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
81 harbaum 110 diff.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
82     diff.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
83     diff.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
84     diff.o: banner.h
85 achadwick 129 gps.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
86 harbaum 110 gps.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
87     gps.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
88     gps.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
89     gps.o: banner.h
90 achadwick 129 icon.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
91 harbaum 110 icon.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
92     icon.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
93     icon.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
94     icon.o: banner.h
95 achadwick 129 iconbar.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
96 harbaum 110 iconbar.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
97     iconbar.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
98     iconbar.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
99     iconbar.o: net_io.h banner.h
100 achadwick 129 info.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
101 harbaum 110 info.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
102     info.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
103     info.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
104     info.o: banner.h
105 achadwick 129 josm_elemstyles.o: appdata.h pos.h osm.h canvas.h undo.h map.h
106 harbaum 110 josm_elemstyles.o: map_hl.h osm_api.h project.h statusbar.h area_edit.h
107     josm_elemstyles.o: settings.h diff.h iconbar.h icon.h info.h track.h gps.h
108     josm_elemstyles.o: wms.h josm_presets.h relation_edit.h misc.h map_edit.h
109     josm_elemstyles.o: josm_elemstyles.h style.h net_io.h banner.h
110 achadwick 129 josm_presets.o: appdata.h pos.h osm.h canvas.h undo.h map.h
111 harbaum 110 josm_presets.o: map_hl.h osm_api.h project.h statusbar.h area_edit.h
112     josm_presets.o: settings.h diff.h iconbar.h icon.h info.h track.h gps.h wms.h
113     josm_presets.o: josm_presets.h relation_edit.h misc.h map_edit.h
114     josm_presets.o: josm_elemstyles.h style.h net_io.h banner.h
115 achadwick 129 main.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
116 harbaum 110 main.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
117     main.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
118     main.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
119     main.o: banner.h
120 achadwick 129 map.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
121 harbaum 110 map.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
122     map.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
123     map.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
124     map.o: banner.h
125 achadwick 129 map_edit.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
126 harbaum 110 map_edit.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
127     map_edit.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
128     map_edit.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
129     map_edit.o: net_io.h banner.h
130 achadwick 129 map_hl.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
131 harbaum 110 map_hl.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
132     map_hl.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
133     map_hl.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
134     map_hl.o: net_io.h banner.h
135 achadwick 129 misc.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
136 harbaum 110 misc.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
137     misc.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
138     misc.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
139     misc.o: banner.h
140 achadwick 129 net_io.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
141 harbaum 110 net_io.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
142     net_io.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
143     net_io.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
144     net_io.o: net_io.h banner.h
145 achadwick 129 osm.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
146 harbaum 110 osm.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
147     osm.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
148     osm.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
149     osm.o: banner.h
150 achadwick 129 osm_api.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
151 harbaum 110 osm_api.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
152     osm_api.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
153     osm_api.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
154     osm_api.o: net_io.h banner.h
155 achadwick 129 pos.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
156 harbaum 110 pos.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
157     pos.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
158     pos.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
159     pos.o: banner.h
160 achadwick 129 project.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
161 harbaum 110 project.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
162     project.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
163     project.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
164     project.o: net_io.h banner.h
165 achadwick 129 relation_edit.o: appdata.h pos.h osm.h canvas.h undo.h map.h
166 harbaum 110 relation_edit.o: map_hl.h osm_api.h project.h statusbar.h area_edit.h
167     relation_edit.o: settings.h diff.h iconbar.h icon.h info.h track.h gps.h
168     relation_edit.o: wms.h josm_presets.h relation_edit.h misc.h map_edit.h
169     relation_edit.o: josm_elemstyles.h style.h net_io.h banner.h
170 achadwick 129 settings.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
171 harbaum 110 settings.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
172     settings.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
173     settings.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
174     settings.o: net_io.h banner.h
175 achadwick 129 statusbar.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
176 harbaum 110 statusbar.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
177     statusbar.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
178     statusbar.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h
179     statusbar.o: net_io.h banner.h
180 achadwick 129 style.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
181 harbaum 110 style.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
182     style.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
183     style.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
184     style.o: banner.h
185 achadwick 129 track.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
186 harbaum 110 track.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
187     track.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
188     track.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
189     track.o: banner.h
190 achadwick 129 undo.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
191 harbaum 110 undo.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
192     undo.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
193     undo.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
194     undo.o: banner.h
195 achadwick 129 wms.o: appdata.h pos.h osm.h canvas.h undo.h map.h map_hl.h
196 harbaum 110 wms.o: osm_api.h project.h statusbar.h area_edit.h settings.h diff.h
197     wms.o: iconbar.h icon.h info.h track.h gps.h wms.h josm_presets.h
198     wms.o: relation_edit.h misc.h map_edit.h josm_elemstyles.h style.h net_io.h
199     wms.o: banner.h