Contents of /branches/ports/maemo/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 63 - (show annotations)
Sun Feb 8 22:52:48 2009 UTC (15 years, 2 months ago) by achadwick
File size: 2099 byte(s)
Update from trunk; make it build properly with the new stuff.
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12
13
14
15 CFLAGS = -Wall -g
16
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -O0
19 else
20 CFLAGS += -O2
21 endif
22
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 # Add here commands to configure the package.
27
28 touch configure-stamp
29
30 -include version.mk
31
32 build: build-stamp
33
34 build-stamp: configure-stamp
35 dh_testdir
36
37 # Add here commands to compile the package.
38 VERSION_PREFIX=`debian/parse-changelog prefix $(TRUNK_VERSION)` \
39 VERSION_SUFFIX=`debian/parse-changelog suffix $(TRUNK_VERSION)` \
40 $(MAKE) -f Makefile.maemo
41 #docbook-to-man debian/osm2go.sgml > osm2go.1
42
43 touch $@
44
45 clean:
46 dh_testdir
47 dh_testroot
48 rm -f build-stamp configure-stamp
49
50 # Add here commands to clean up after the build process.
51 -$(MAKE) clean
52
53 dh_clean
54
55 install: build
56 dh_testdir
57 dh_testroot
58 dh_clean -k
59 dh_installdirs
60
61 # Add here commands to install the package into debian/osm2go.
62 $(MAKE) -f Makefile.maemo DESTDIR=$(CURDIR)/debian/osm2go install
63
64
65 # Build architecture-independent files here.
66 binary-indep: build install
67 # We have nothing to do by default.
68
69 # Build architecture-dependent files here.
70 binary-arch: build install
71 dh_testdir
72 dh_testroot
73 dh_installchangelogs
74 dh_installdocs
75 dh_installexamples
76 # dh_install
77 # dh_installmenu
78 # dh_installdebconf
79 # dh_installlogrotate
80 # dh_installemacsen
81 # dh_installpam
82 # dh_installmime
83 # dh_python
84 # dh_installinit
85 # dh_installcron
86 # dh_installinfo
87 dh_installman
88 dh_link
89 dh_strip
90 dh_compress
91 dh_fixperms
92 # dh_perl
93 # dh_makeshlibs
94 dh_installdeb
95 dh_shlibdeps
96 dh_gencontrol
97 dh_md5sums
98 dh_builddeb
99
100 binary: binary-indep binary-arch
101 .PHONY: build clean binary-indep binary-arch binary install configure