Contents of /branches/ports/maemo/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 138 - (hide annotations)
Sat Mar 21 23:36:32 2009 UTC (15 years, 2 months ago) by achadwick
File size: 2275 byte(s)
Build updates for maemo
1 harbaum 1 #!/usr/bin/make -f
2     # -*- makefile -*-
3     # Sample debian/rules that uses debhelper.
4     # This file was originally written by Joey Hess and Craig Small.
5     # As a special exception, when this file is copied by dh-make into a
6     # dh-make output file, you may use that output file without restriction.
7     # This special exception was added by Craig Small in version 0.37 of dh-make.
8    
9     # Uncomment this to turn on verbose mode.
10     #export DH_VERBOSE=1
11    
12    
13    
14    
15     CFLAGS = -Wall -g
16    
17     ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18     CFLAGS += -O0
19     else
20     CFLAGS += -O2
21     endif
22    
23 achadwick 138 configure: configure-stamp
24     configure-stamp:
25 harbaum 1 # Add here commands to configure the package.
26 achadwick 138 dh_testdir
27     ./configure --prefix=/usr
28     #--exec-prefix=/usr
29     #XXX dh_auto_configure
30     touch "$@"
31 harbaum 1
32     build: build-stamp
33    
34 achadwick 138 build-stamp: configure-stamp
35 harbaum 1 # Add here commands to compile the package.
36 achadwick 138 dh_testdir
37     #XXX dh_auto_build
38     DESTDIR=`pwd`/debian/osm2go $(MAKE)
39     # VERSION_PREFIX=`perl debian/parse-changelog prefix $(TRUNK_VERSION)` \
40     # VERSION_SUFFIX=`perl debian/parse-changelog suffix $(TRUNK_VERSION)` \
41     # $(MAKE)
42 harbaum 1 #docbook-to-man debian/osm2go.sgml > osm2go.1
43     touch $@
44    
45 achadwick 138 clean: configure-stamp
46     # Add here commands to clean up after the build process.
47 harbaum 1 dh_testdir
48     dh_testroot
49 achadwick 138 #XXX dh_auto_clean
50     $(MAKE) distclean
51 harbaum 1 rm -f build-stamp configure-stamp
52     dh_clean
53    
54     install: build
55 achadwick 138 # Add here commands to install the package into debian/osm2go.
56 harbaum 1 dh_testdir
57     dh_testroot
58     dh_clean -k
59     dh_installdirs
60 achadwick 138 #XXX dh_auto_install
61     DESTDIR=`pwd`/debian/osm2go $(MAKE) install
62 harbaum 1
63     # Build architecture-independent files here.
64     binary-indep: build install
65     # We have nothing to do by default.
66    
67     # Build architecture-dependent files here.
68     binary-arch: build install
69     dh_testdir
70     dh_testroot
71 achadwick 138 # dh_installchangelogs ChangeLog
72     # dh_installdocs
73     # dh_installexamples
74 harbaum 1 # dh_install
75     # dh_installmenu
76 achadwick 138 dh_desktop
77     #XXX dh_icons
78 harbaum 1 # dh_installdebconf
79     # dh_installlogrotate
80     # dh_installemacsen
81     # dh_installpam
82     # dh_installmime
83     # dh_python
84     # dh_installinit
85     # dh_installcron
86     # dh_installinfo
87 achadwick 138 # dh_installman data/osm2go.1
88 harbaum 1 dh_link
89     dh_strip
90     dh_compress
91     dh_fixperms
92     # dh_perl
93     # dh_makeshlibs
94     dh_installdeb
95     dh_shlibdeps
96     dh_gencontrol
97     dh_md5sums
98     dh_builddeb
99    
100     binary: binary-indep binary-arch
101     .PHONY: build clean binary-indep binary-arch binary install configure