Contents of /branches/ports/maemo/Makefile.maemo

Parent Directory Parent Directory | Revision Log Revision Log


Revision 86 - (show annotations)
Tue Feb 17 20:26:27 2009 UTC (15 years, 2 months ago) by harbaum
File size: 1230 byte(s)
Minor maemo build fixes
1 #
2 # Copyright (C) 2008 Till Harbaum <till@harbaum.org>.
3 #
4 # This file is part of OSM2Go.
5 #
6 # OSM2Go is free software: you can redistribute it and/or modify
7 # it under the terms of the GNU General Public License as published by
8 # the Free Software Foundation, either version 3 of the License, or
9 # (at your option) any later version.
10 #
11 # OSM2Go is distributed in the hope that it will be useful,
12 # but WITHOUT ANY WARRANTY; without even the implied warranty of
13 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 # GNU General Public License for more details.
15 #
16 # You should have received a copy of the GNU General Public License
17 # along with OSM2Go. If not, see <http://www.gnu.org/licenses/>.
18 #
19
20 all:
21 cd src && make -f Makefile.maemo
22 cd data && make -f Makefile.maemo
23
24 install:
25 cd src && make -f Makefile.maemo install
26 cd data && make -f Makefile.maemo install
27
28 clean:
29 rm -f *~ \#*\# *.bak *-stamp
30 cd src && make -f Makefile.maemo clean
31 cd data && make -f Makefile.maemo clean
32
33 distclean: clean
34
35 ChangeLog: FORCE
36 svn2cl --group-by-day --include-rev --separate-daylogs --include-actions
37
38 -include version.mk
39
40 tarball: distclean
41 sh mktarball.sh "$(VERSION_PREFIX)$(TRUNK_VERSION)$(VERSION_SUFFIX)"
42
43 FORCE:
44

Properties

Name Value
svn:mergeinfo