Contents of /trunk/debian/rules

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1 - (show annotations)
Sat Jun 20 11:08:47 2009 UTC (14 years, 10 months ago) by harbaum
File size: 1945 byte(s)
Initial import
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12
13
14
15 CFLAGS = -Wall -g
16
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -O0
19 else
20 CFLAGS += -O2
21 endif
22
23 configure: configure-stamp
24 configure-stamp:
25 dh_testdir
26 # Add here commands to configure the package.
27 ./configure --prefix=/usr
28 touch configure-stamp
29
30
31 build: build-stamp
32
33 build-stamp: configure-stamp
34 dh_testdir
35
36 # Add here commands to compile the package.
37 $(MAKE) -f Makefile
38 #docbook-to-man debian/gpxview.sgml > gpxview.1
39
40 touch $@
41
42 clean:
43 dh_testdir
44 dh_testroot
45 rm -f build-stamp configure-stamp
46
47 # Add here commands to clean up after the build process.
48 -$(MAKE) clean
49
50 dh_clean
51
52 install: build
53 dh_testdir
54 dh_testroot
55 dh_clean -k
56 dh_installdirs
57
58 # Add here commands to install the package into debian/gpxview.
59 $(MAKE) DESTDIR=$(CURDIR)/debian/gpxview install
60
61
62 # Build architecture-independent files here.
63 binary-indep: build install
64 # We have nothing to do by default.
65
66 # Build architecture-dependent files here.
67 binary-arch: build install
68 dh_testdir
69 dh_testroot
70 dh_installchangelogs
71 dh_installdocs
72 dh_installexamples
73 # dh_install
74 # dh_installmenu
75 # dh_installdebconf
76 # dh_installlogrotate
77 # dh_installemacsen
78 # dh_installpam
79 # dh_installmime
80 # dh_python
81 # dh_installinit
82 # dh_installcron
83 # dh_installinfo
84 dh_installman
85 dh_link
86 dh_strip
87 dh_compress
88 dh_fixperms
89 # dh_perl
90 # dh_makeshlibs
91 dh_installdeb
92 dh_shlibdeps
93 dh_gencontrol
94 dh_md5sums
95 dh_builddeb
96
97 binary: binary-indep binary-arch
98 .PHONY: build clean binary-indep binary-arch binary install configure

Properties

Name Value
svn:executable