Changed source template from the C++ one, in esbox, to the C one. Added librest as...
[maevies] / debian / rules
index 183465b..88fd184 100644 (file)
@@ -1,23 +1,29 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
 # Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# GNU copyright 1997 to 1999 by Joey Hess.
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+
 CFLAGS = -Wall -g
+PACKAGENAME = maevies
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
 else
        CFLAGS += -O2
 endif
-
-CXXFLAGS = $(CFLAGS)
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+       INSTALL_PROGRAM += -s
+endif
 
 configure: configure-stamp
 configure-stamp:
@@ -29,34 +35,34 @@ configure-stamp:
 
 build: build-stamp
 
-build-stamp: configure-stamp 
+build-stamp:  configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
        $(MAKE)
-       #docbook-to-man debian/maevies.sgml > maevies.1
-
-       touch $@
+       touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp configure-stamp 
 
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
+       mv debian/rules debian/rules.save
+       -$(MAKE) distclean
+       mv debian/rules.save debian/rules
 
-       dh_clean 
+       dh_clean
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_clean -k
        dh_installdirs
 
-       # Add here commands to install the package into debian/maevies.
-       $(MAKE) DESTDIR=$(CURDIR)/debian/maevies install
-
+    # Add here commands to install the package into debian/$(PACKAGENAME)
+       $(MAKE) DESTDIR=$(CURDIR)/debian/$(PACKAGENAME) install
+    
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -66,27 +72,10 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installexamples
-#      dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
@@ -94,4 +83,4 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: build clean binary-indep binary-arch binary install