update busybox-power against BusyBox 1.21 release
[busybox-power] / debian / rules
index 476ccf7..fb33451 100755 (executable)
@@ -14,7 +14,7 @@ ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
        CONFIG_DEBUG = y
 endif
 ifneq (,$(findstring thumb,$(DEB_BUILD_OPTIONS)))
-THUMB := -mthumb
+       THUMB := -mthumb
 endif
 
 ifneq (,$(findstring parallel,$(DEB_BUILD_OPTIONS)))
@@ -49,6 +49,8 @@ $(STAMPS_DIR)/setup_%: $(STAMPS_DIR)/source
        rm -rf '$(DIR)'
        cp -al '$(SOURCE_DIR)' '$(DIR)'
        cp debian/config/config.$* '$(DIR)'/.config
+       grep -qv Diablo /etc/maemo_version \
+               || cp debian/config/config.$*.diablo '$(DIR)'/.config
        make -C '$(DIR)' oldconfig
        touch $@
 
@@ -83,10 +85,8 @@ binary-arch_busybox: $(STAMPS_DIR)/build_busybox
        dh_testroot
        dh_clean -k -d
        install -D -m644 debian/scripts/applets debian/busybox-power/opt/busybox-power/applets
-       install -D -m755 debian/scripts/install-binary.sh debian/busybox-power/opt/busybox-power/install-binary.sh
-       install -D -m755 debian/scripts/uninstall-binary.sh debian/busybox-power/opt/busybox-power/uninstall-binary.sh
+       install -D -m644 debian/scripts/functions debian/busybox-power/opt/busybox-power/functions
        install -D -m755 $(DIR)/busybox_unstripped debian/busybox-power/opt/busybox-power/busybox.power
-       install -D -m600 debian/scripts/environment debian/busybox-power/etc/environment
 
 binary-arch_all:
        dh_installdirs