Remove faulty "make clean" step from debian/rules
[ameter] / debian / rules
index 7989954..618739a 100755 (executable)
@@ -1,35 +1,22 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
 
 APPNAME := ameter
 
-
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
        qmake PREFIX=/usr $(APPNAME).pro
-
-       touch configure-stamp
-
+       touch $@
 
 build: build-stamp
 
 build-stamp: configure-stamp  
        dh_testdir
-
        # Add here commands to compile the package.
        $(MAKE) $(APPNAME)
-       #docbook-to-man debian/ameter.sgml > ameter.1
-
        touch $@
 
 clean: 
@@ -39,6 +26,9 @@ clean:
 
        # Add here commands to clean up after the build process.
        # $(MAKE) clean
+       rm -f $(APPNAME)
+       rm -f *.o
+       rm -f moc_*.cpp
 
        dh_clean 
 
@@ -49,7 +39,7 @@ install: build
        dh_installdirs
 
        # Add here commands to install the package into debian/ameter.
-       $(MAKE) INSTALL_ROOT="$(CURDIR)"/debian/$(APPNAME) install
+       $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
 
 
 # Build architecture-independent files here.
@@ -63,24 +53,10 @@ binary-arch: build install
        dh_installchangelogs 
        dh_installdocs
        dh_installexamples
-#      dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps # Uncomment this line for use without Qt Creator
        dh_gencontrol