Removing evas patches, already applied upstream.
[maemo-efl] / trunk / evas / debian / rules
index c4c826a..c0de473 100755 (executable)
@@ -2,7 +2,6 @@
 
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
 
 DEB_CONFIGURE_EXTRA_FLAGS := --enable-software-16-x11                  \
                                                         --enable-software-x11                          \
@@ -29,9 +28,6 @@ DEB_CONFIGURE_EXTRA_FLAGS := --enable-software-16-x11                 \
                                                         --disable-convert-16-rgb-555           \
                                                         --disable-convert-16-rgb-444           \
                                                         --disable-convert-16-rgb-ipq           \
-                                                        --disable-convert-16-rgb-rot-180       \
-                                                        --disable-convert-16-rgb-rot-270       \
-                                                        --disable-convert-16-rgb-rot-90        \
                                                         --disable-convert-24-rgb-888           \
                                                         --disable-convert-24-bgr-888           \
                                                         --disable-convert-32-rgb-8888          \
@@ -44,10 +40,18 @@ DEB_CONFIGURE_EXTRA_FLAGS := --enable-software-16-x11                       \
                                                         --disable-convert-32-rgb-rot-90        \
                                                         --disable-sdl
 
+CFLAGS += -I/usr/X11R6/include
 
 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 
 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
-       CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+       CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+       ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
+               CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
+       endif
+       ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
+               CFLAGS += -mcpu=arm926ej-s
+       endif
 endif
 
+