Removing evas patches, already applied upstream.
[maemo-efl] / trunk / evas / debian / rules
index 4ae6500..c0de473 100755 (executable)
@@ -2,7 +2,6 @@
 
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
 
 DEB_CONFIGURE_EXTRA_FLAGS := --enable-software-16-x11                  \
                                                         --enable-software-x11                          \
@@ -41,12 +40,12 @@ DEB_CONFIGURE_EXTRA_FLAGS := --enable-software-16-x11                       \
                                                         --disable-convert-32-rgb-rot-90        \
                                                         --disable-sdl
 
+CFLAGS += -I/usr/X11R6/include
 
 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 
-CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2
-
 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
+       CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
        ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
                CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
        endif