Added specific build options depending on the target device
[maemo-efl] / trunk / embryo / debian / rules
index 4efb562..9444fbb 100755 (executable)
@@ -5,16 +5,14 @@ include /usr/share/cdbs/1/class/autotools.mk
 include /usr/share/cdbs/1/rules/patchsys-quilt.mk
 
 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-
-CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2
                                                                                  
 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
-        CFLAGS += -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
-        ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
-                CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
-        endif
-        ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
-                CFLAGS += -mcpu=arm926ej-s
-        endif
+       CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+       ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
+               CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
+       endif
+       ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
+               CFLAGS += -mcpu=arm926ej-s
+       endif
 endif