Added specific build options depending on the target device
[maemo-efl] / trunk / eet / debian / rules
index d4e56da..e94e71f 100755 (executable)
@@ -6,15 +6,13 @@ include /usr/share/cdbs/1/rules/simple-patchsys.mk
 
 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 
-CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2
-
 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
-       CFLAGS += -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+       CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
        ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
                CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
        endif
        ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
-                CFLAGS += -mcpu=arm926ej-s 
+                CFLAGS += -mcpu=arm926ej-s
        endif
 endif