Added maemo-cflags-cdbs-rules as dependency
[maemo-efl] / trunk / ecore / debian / rules
index da4d837..2239164 100755 (executable)
@@ -2,9 +2,11 @@
 
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
-include /usr/share/cdbs/1/rules/patchsys-quilt.mk
+include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/maemo-cflags.mk
 
-DEB_CONFIGURE_EXTRA_FLAGS :=  --enable-ecore-evas-x11-16       \
+DEB_CONFIGURE_SCRIPT := ./autogen.sh
+DEB_CONFIGURE_EXTRA_FLAGS :=  --enable-ecore-evas-software-16-x11      \
                                                          --disable-ecore-fb                    \
                                                          --disable-ecore-directfb              \
                                                          --disable-ecore-evas-gl               \
@@ -16,17 +18,5 @@ DEB_CONFIGURE_EXTRA_FLAGS :=  --enable-ecore-evas-x11-16     \
 
 DEB_CONFIGURE_SCRIPT_ENV += CURL_LIBS="-lcurl"
 
-DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-
-CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2
-                                                                                
-ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
-       CFLAGS += -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
-       ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
-               CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
-       endif
-       ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
-               CFLAGS += -mcpu=arm926ej-s
-       endif
-endif
+CFLAGS += -I/usr/X11R6/include