Added maemo-cflags-cdbs-rules as dependency
[maemo-efl] / trunk / ecore / debian / rules
index c5eefb6..2239164 100755 (executable)
@@ -3,8 +3,10 @@
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
 include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/maemo-cflags.mk
 
-DEB_CONFIGURE_EXTRA_FLAGS :=  --enable-ecore-evas-x11-16       \
+DEB_CONFIGURE_SCRIPT := ./autogen.sh
+DEB_CONFIGURE_EXTRA_FLAGS :=  --enable-ecore-evas-software-16-x11      \
                                                          --disable-ecore-fb                    \
                                                          --disable-ecore-directfb              \
                                                          --disable-ecore-evas-gl               \
@@ -16,9 +18,5 @@ DEB_CONFIGURE_EXTRA_FLAGS :=  --enable-ecore-evas-x11-16      \
 
 DEB_CONFIGURE_SCRIPT_ENV += CURL_LIBS="-lcurl"
 
-DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-
-ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
-       CFLAGS := $(CFLAGS) -DNDEBUG=1 -fomit-frame-pointer -O2 -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
-endif
+CFLAGS += -I/usr/X11R6/include