Updated debian stuff
[lms] / packages / python-lightmediascanner / debian / rules
index 123917c..d6a842f 100755 (executable)
@@ -1,58 +1,12 @@
 #!/usr/bin/make -f
+# -*- mode: makefile; coding: utf-8 -*-
 
-PYVER=2.5
-PYTHON=python$(PYVER)
+DEB_PYTHON_SYSTEM := pycentral
 
-p_base=$(PYTHON)-lightmediascanner
-d_base=debian/$(p_base)
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/python-distutils.mk
 
-DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
+clean::
+       find lightmediascanner -name '*.c' | xargs rm -rf
+       rm -rf python_lightmediascanner.egg-info
 
-ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
-    CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
-    ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
-        CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
-    endif
-    ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
-         CFLAGS += -mcpu=arm926ej-s
-    endif
-endif
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-       touch lightmediascanner/lightmediascanner.*.pyx
-       CFLAGS="$(CFLAGS)" $(PYTHON) setup.py build_ext build install --prefix /usr install_headers
-       touch build-stamp
-clean:
-       dh_testdir
-       dh_testroot
-       $(PYTHON) setup.py clean
-       -rm -f build-stamp
-       -rm -rf build dist python_lightmediascanner.egg-info
-       -rm -f lightmediascanner/*.py[co]
-       -rm -f *.py[co]
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_installdirs
-
-       $(PYTHON) setup.py install --root=$(d_base)
-
-binary: binary-indep binary-arch
-binary-indep: install
-binary-arch: install
-       dh_testdir
-       dh_testroot
-       dh_strip
-       dh_fixperms
-       dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-.PHONY: build install clean binary binary-indep binary-arch