fixed dependencies in debian/control & paths in debian/rules
[findit] / debian / rules
index def22fb..f959cfa 100755 (executable)
@@ -1,40 +1,27 @@
 #!/usr/bin/make -f
 # -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
 build: build-stamp
 
-build-stamp: configure-stamp  
+build-stamp:
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE)
-       #docbook-to-man debian/findit.sgml > findit.1
-
+       mkdir -p $(CURDIR)/po/ru/
+       msgfmt $(CURDIR)/po/ru.po -o $(CURDIR)/po/ru/findit.mo
+       python setup.py build
        touch $@
 
-clean: 
+clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp
+       rm -rf $(CURDIR)/po/ru
 
        # Add here commands to clean up after the build process.
-       $(MAKE) clean
+       python setup.py clean --all
 
        dh_clean 
 
@@ -42,46 +29,27 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k 
-       dh_installdirs
-
-       # Add here commands to install the package into debian/findit.
-       $(MAKE) DESTDIR=$(CURDIR)/debian/findit install
 
+       # Add here commands to install the package into debian/findit
+       python setup.py install --root $(CURDIR)/debian/findit
 
 # Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs 
        dh_installdocs
-       dh_installexamples
-#      dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
        dh_link
-       dh_strip
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
        dh_installdeb
-       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
+# Build architecture-dependent files here.
+binary-arch: build install
+
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+
+.PHONY: build clean binary-indep binary-arch binary install