Moar debianization
[irwi] / debian / rules
index fb2d8db..ac2e4f5 100755 (executable)
@@ -1,64 +1,34 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-
-
-
-CFLAGS = -Wall
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
-else
-       CFLAGS += -O2
-endif
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
+APPNAME := irwi
+builddir:
+       mkdir -p builddir
 
+builddir/Makefile: builddir
+       cd builddir && qmake-qt4 PREFIX=/usr ../$(APPNAME).pro
 
 build: build-stamp
 
-build-stamp: configure-stamp 
+build-stamp: builddir/Makefile
        dh_testdir
-
        # Add here commands to compile the package.
-       $(MAKE)
-       #docbook-to-man debian/irwi.sgml > irwi.1
-
+       cd builddir && $(MAKE)
        touch $@
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
-
+       rm -f build-stamp
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
-
-       dh_clean 
-
+       rm -rf builddir
+       dh_clean
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_clean -k
        dh_installdirs
 
-       # Add here commands to install the package into debian/irwi.
-       $(MAKE) DESTDIR=$(CURDIR)/debian/irwi install
-
-
+       # Add here commands to install the package into debian/your_appname
+       cd builddir && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
 # Build architecture-independent files here.
 binary-indep: build install
 # We have nothing to do by default.
@@ -67,27 +37,13 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
-#      dh_installdocs
-#      dh_installexamples
-#      dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
+       dh_installdocs
+       dh_installexamples
        dh_installman
        dh_link
-       dh_strip
+       dh_strip --dbg-package=irwi-dbg
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol