moved commands from binary-arch to binary-indep target in debian/rules
[findit] / debian / rules
index 9d69f4f..3ac28aa 100755 (executable)
@@ -9,13 +9,9 @@ build-stamp: configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
-       mkdir $(CURDIR)/ru
-       mkdir $(CURDIR)/ru/LC_MESSAGES
-       touch $(CURDIR)/ru/LC_MESSAGES/findit.mo
+       mkdir -p $(CURDIR)/ru/LC_MESSAGES
        msgfmt ru.po -o $(CURDIR)/ru/LC_MESSAGES/findit.mo
        python setup.py build
-       #docbook-to-man debian/findit.sgml > findit.1
-
        touch $@
 
 clean:
@@ -40,10 +36,6 @@ install: build
 
 # Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs 
@@ -59,5 +51,8 @@ binary-arch: build install
        dh_md5sums
        dh_builddeb
 
+# Build architecture-dependent files here.
+binary-arch: build install
+
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+.PHONY: build clean binary-indep binary-arch binary install