* Added some power saving features, needs some testing to confirm this is working...
[monky] / debian / rules
index 15577fb..0ceae0b 100644 (file)
@@ -2,7 +2,7 @@
 # -*- makefile -*-
 
 # Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+export DH_VERBOSE=1
 
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
@@ -11,8 +11,10 @@ DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 DEB_HOST_ARCH_OS    ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
 DEB_HOST_ARCH_CPU   ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_CPU)
 
-CFLAGS = -Wall -g
-LDFLAGS = -Wl,--as-needed
+CFLAGS = -Wall -g -mcpu=cortex-a8
+LDFLAGS = -Wl,--as-needed 
+CFLAGS += `pkg-config --cflags dbus-1`
+LDFLAGS += `pkg-config --libs dbus-1`
 
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
        CFLAGS += -O0
@@ -44,30 +46,20 @@ configure: config-stamp
 
 config-stamp:
        dh_testdir
+#DML#  chmod +x ./autogen.sh
+       AUTOMAKE=automake ./autogen.sh
 
-       chmod +x ./autogen.sh
-       AUTOMAKE=automake-1.11 ./autogen.sh
+# copy these instead
+#      ln -sf /usr/share/misc/config.sub .
+#      ln -sf /usr/share/misc/config.guess .
 
-       ln -sf /usr/share/misc/config.sub .
-       ln -sf /usr/share/misc/config.guess .
-
-       mkdir build-std build-cli build-all
-
-       cd build-std && CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
-       ../configure $(COMMON_CONFIGURE_FLAGS) $(LINUX_CONF_ARGS_STD)
-
-       cd build-cli && CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
-       ../configure $(COMMON_CONFIGURE_FLAGS) \
-       --disable-lua --disable-double-buffer --disable-x11 \
-       --disable-xdamage --disable-own-window --disable-xft \
-       --disable-hddtemp --disable-alsa --disable-portmon \
-       --enable-ncurses
+       mkdir build-all
 
        cd build-all && CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" \
        ../configure $(COMMON_CONFIGURE_FLAGS) \
-        --enable-imlib2 --enable-rss --enable-weather-xoap \
-       --enable-eve --enable-lua-cairo --enable-lua-imlib2 \
-       --disable-static --enable-argb \
+        --enable-rss --enable-weather-xoap LUA51_LIBS='-llua5.1 -lm' \
+       --enable-eve --enable-lua=yes --enable-lua-cairo --enable-lua-imlib2 \
+       --disable-static --enable-argb --enable-x11 --enable-imlib2 \
        $(LINUX_CONF_ARGS_ALL) $(ENABLE_NVIDIA)
 
        touch $@
@@ -77,8 +69,6 @@ build: build-stamp
 build-stamp: config-stamp
        dh_testdir
 
-       cd build-std && $(MAKE)
-       cd build-cli && $(MAKE)
        cd build-all && $(MAKE)
 
        touch $@
@@ -91,7 +81,7 @@ clean:
 
        rm  -f configure.ac configure config.h.in src/config.h.in \
               src/defconfig.h compile install-sh missing ltmain.sh depcomp \
-              Makefile.in doc/Makefile.in src/Makefile.in \
+              Makefile.in doc/Makefile.in src/Makefile.in  src/dbus/Makefile.in \
               data/Makefile.in lua/Makefile.in \
               aclocal.m4 m4/libtool.m4 m4/ltversion.m4 \
               m4/lt~obsolete.m4 m4/ltoptions.m4 m4/ltsugar.m4
@@ -106,14 +96,20 @@ install: build
        dh_testroot
        dh_clean -k 
 
-       cd build-std && $(MAKE) install DESTDIR=$(CURDIR)/debian/conky-std
-       cd build-cli && $(MAKE) install DESTDIR=$(CURDIR)/debian/conky-cli
-       cd build-all && $(MAKE) install DESTDIR=$(CURDIR)/debian/conky-all
+       cd build-all && $(MAKE) install DESTDIR=$(CURDIR)/debian/conky-n950
+       mkdir -p debian/conky-n950/usr/share/icons/hicolor/scalable/apps/
+       cp -p debian/conkylogo64.png debian/conky-n950/usr/share/icons/hicolor/scalable/apps/conky.png
+       mkdir -p debian/conky-n950/usr/share/icons/hicolor/48x48/apps/
+       cp -p debian/conkylogo48.png debian/conky-n950/usr/share/icons/hicolor/48x48/apps/conky.png
+       mkdir -p debian/conky-n950/usr/share/applications/
+       cp -p debian/conky.desktop debian/conky-n950/usr/share/applications/conky.desktop
+       mkdir -p debian/conky-n950/usr/bin/
+       cp -p debian/conky.sh debian/conky-n950/usr/bin/
 
        # Clean up cruft left upstream
        rm -rf debian/conky-std/usr/lib debian/conky-cli/usr/lib \
-              debian/conky-all/usr/lib/conky/*.la \
-              debian/conky-all/usr/lib/conky/*.so.?
+              debian/conky-n950/usr/lib/conky/*.la \
+              debian/conky-n950/usr/lib/conky/*.so.?
 
 binary-indep: build install
 
@@ -122,15 +118,15 @@ binary-arch: build install
        dh_testroot
        dh_installchangelogs ChangeLog
        dh_installdocs
-       dh_installmenu -a
+       dh_installmenu
        dh_installman -a doc/conky.1
-       dh_install -a
-       dh_link -a
-       dh_strip -a
+       dh_install
+       dh_link
+       dh_strip
        dh_compress
        dh_fixperms
-       dh_installdeb -a
-       dh_shlibdeps -a
+       dh_installdeb
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb