ebuild update
[monky] / app-admin / conky / conky-1.9999.ebuild
index a39fab2..259ad6e 100644 (file)
@@ -11,20 +11,19 @@ HOMEPAGE="http://conky.sf.net"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="truetype seti metar X"
+IUSE="truetype seti X"
 
 RDEPEND="virtual/libc
    X? ( virtual/x11 )
    truetype? ( >=media-libs/freetype-2 )
    seti? ( sci-astronomy/setiathome )
-   metar? ( dev-libs/mdsplib )
    "
 
 DEPEND="truetype? ( >=media-libs/freetype-2 )
-   metar? ( dev-libs/mdsplib )
    X? ( virtual/x11 )
-   >=sys-devel/automake-1.4
-   sys-devel/autoconf
+   >=sys-devel/automake-1.9
+   >=sys-devel/autoconf-2.59
+   sys-devel/libtool
    sys-apps/grep
    sys-apps/sed
    sys-devel/gcc
@@ -39,23 +38,20 @@ src_unpack() {
 }
 
 src_compile() {
-   econf \
-      $(use_enable truetype xft) \
-      $(use_enable metar) \
-      $(use_enable seti) \
-         $(use_enable x x11) \
-      --enable-double-buffer \
-      --enable-own-window \
-      --enable-proc-uptime \
-         --enable-mpd \
-         --enable-mldonkey \
-      || die "econf failed"
-   emake || die "compile failed"
+    local myconf
+    myconf="--enable-double-buffer --enable-own-window --enable-proc-uptime --enable-mpd --enable-mldonkey"
+    econf \
+        ${myconf} \
+        $(use_enable truetype xft) \
+        $(use_enable X x11) \
+        $(use_enable !ipv6 portmon) \
+        $(use_enable seti) || die "econf failed"
+    emake || die "compile failed"
 }
 
 src_install() {
    emake DESTDIR=${D} install || die "make install failed"
-   dodoc ChangeLog AUTHORS README conkyrc.sample
+   dodoc ChangeLog AUTHORS README doc/conkyrc.sample
 }
 
 pkg_postinst() {