ebuild update
[monky] / app-admin / conky / conky-1.9999.ebuild
index 8b65f2f..259ad6e 100644 (file)
@@ -1,33 +1,32 @@
-# CVS ebuild for Conky
+# CVS ebuild for Conky, thanks to Hopeless
 # $Header$
 
 ECVS_SERVER="cvs.sourceforge.net:/cvsroot/conky"
 ECVS_MODULE="conky"
 inherit cvs
 
-DESCRIPTION="minimalist system monitor for X based on torsmo"
-HOMEPAGE="http://conky.rty.ca"
+DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
+HOMEPAGE="http://conky.sf.net"
 
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="truetype seti metar mldonkey mpd"
+IUSE="truetype seti X"
 
 RDEPEND="virtual/libc
-   virtual/x11
+   X? ( virtual/x11 )
    truetype? ( >=media-libs/freetype-2 )
    seti? ( sci-astronomy/setiathome )
-   metar? ( dev-libs/mdsplib )"
+   "
 
 DEPEND="truetype? ( >=media-libs/freetype-2 )
-   metar? ( dev-libs/mdsplib )
-   virtual/x11
-   >=sys-devel/automake-1.4
-   sys-devel/autoconf
+   X? ( virtual/x11 )
+   >=sys-devel/automake-1.9
+   >=sys-devel/autoconf-2.59
+   sys-devel/libtool
    sys-apps/grep
    sys-apps/sed
    sys-devel/gcc
-   >=sys-process/procps-3.2.5
    "
 
 S=${WORKDIR}/conky
@@ -39,22 +38,20 @@ src_unpack() {
 }
 
 src_compile() {
-   econf \
-      $(use_enable truetype xft) \
-      $(use_enable metar) \
-      $(use_enable mldonkey) \
-      $(use_enable mpd) \
-      $(use_enable seti) \
-      --enable-double-buffer \
-      --enable-own-window \
-      --enable-proc-uptime \
-      || die "econf failed"
-   emake || die "compile failed"
+    local myconf
+    myconf="--enable-double-buffer --enable-own-window --enable-proc-uptime --enable-mpd --enable-mldonkey"
+    econf \
+        ${myconf} \
+        $(use_enable truetype xft) \
+        $(use_enable X x11) \
+        $(use_enable !ipv6 portmon) \
+        $(use_enable seti) || die "econf failed"
+    emake || die "compile failed"
 }
 
 src_install() {
    emake DESTDIR=${D} install || die "make install failed"
-   dodoc ChangeLog AUTHORS README conkyrc.sample
+   dodoc ChangeLog AUTHORS README doc/conkyrc.sample
 }
 
 pkg_postinst() {