Conky 1.4.9
[monky] / app-admin / conky / conky-1.4.3.ebuild
index 6ea92e5..02b2a9c 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header$
+# $Header: $
 
 inherit eutils
 
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="truetype X ipv6 bmpx bmp xmms xmms2 infopipe audacious"
+IUSE="truetype X ipv6 audacious bmpx hddtemp mpd vim-syntax"
 
 DEPEND_COMMON="
        virtual/libc
@@ -21,19 +21,21 @@ DEPEND_COMMON="
                                x11-libs/libX11
                                x11-libs/libSM
                                x11-libs/libXrender
+                               x11-libs/libXdamage
                                x11-libs/libXft
                                )
                                virtual/x11
                )
                truetype? ( >=media-libs/freetype-2 )
+               audacious? ( >=media-sound/audacious-0.1 )
                bmpx? ( media-sound/bmpx
                                >=sys-apps/dbus-0.35
                        )
-               audacious? ( >=media-sound/audacious-0.1 )
-               xmms2? ( medis-sound/xmms2 )
        )"
 
-RDEPEND="${DEPEND_COMMON}"
+RDEPEND="${DEPEND_COMMON}
+       hddtemp? ( app-admin/hddtemp )
+       mpd? ( media-sound/mpd )"
 
 DEPEND="
        ${DEPEND_COMMON}
@@ -48,42 +50,41 @@ DEPEND="
        sys-apps/grep
        sys-apps/sed"
 
+PDEPEND="vim-syntax? ( app-vim/conky-syntax )"
+
 src_compile() {
        local mymake
        if useq ipv6 ; then
                ewarn
-               ewarn "You have the ipv6 USE flag enabled.  Please note that"
-               ewarn "using the ipv6 USE flag with Conky disables the port"
-               ewarn "monitor."
-               ewarn
+               ewarn "You have the ipv6 USE flag enabled.  Please note that using"
+               ewarn "the ipv6 USE flag with Conky disables the port monitor."
                epause
        else
                mymake="MPD_NO_IPV6=noipv6"
        fi
        local myconf
-       myconf="--enable-double-buffer --enable-own-window --enable-proc-uptime \
-               --enable-mpd --enable-mldonkey"
+       myconf="--enable-own-window --enable-proc-uptime"
+       use X && myconf="${myconf} --enable-x11 --enable-double-buffer --enable-xdamage"
        econf \
                ${myconf} \
                $(use_enable truetype xft) \
-               $(use_enable X x11) \
-               $(use_enable bmpx) \
-               $(use_enable xmms2) \
                $(use_enable audacious) \
-               $(use_enable infopipe) \
+               $(use_enable bmpx) \
+               $(use_enable hddtemp ) \
+               $(use_enable mpd) \
                $(use_enable !ipv6 portmon) || die "econf failed"
        emake ${mymake} || die "compile failed"
 }
 
 src_install() {
-       make DESTDIR=${D} install || die "make install failed"
+       emake DESTDIR=${D} install || die "make install failed"
        dodoc ChangeLog AUTHORS README doc/conkyrc.sample
-       dohtml doc/variables.html doc/docs.html doc/config_settings.html
+       dohtml doc/docs.html doc/config_settings.html doc/variables.html
 }
 
 pkg_postinst() {
        einfo 'Default configuration file is "~/.conkyrc"'
-       einfo "you can find a sample configuration file in"
+       einfo "You can find a sample configuration file in"
        einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
        einfo
        einfo "For more info on Conky's new features,"
@@ -93,6 +94,8 @@ pkg_postinst() {
        einfo "There are also pretty html docs available"
        einfo "on Conky's site or in /usr/share/doc/${PF}"
        einfo
+       einfo "Also see http://www.gentoo.org/doc/en/conky-howto.xml"
+       einfo
        einfo "Check out app-vim/conky-syntax for conkyrc"
        einfo "syntax highlighting in Vim"
        einfo