small fixes, updated ebuild
[monky] / app-admin / conky / conky-1.9999.ebuild
1 # CVS ebuild for Conky, thanks to Hopeless
2 # $Header$
3
4 ECVS_SERVER="cvs.sourceforge.net:/cvsroot/conky"
5 ECVS_MODULE="conky"
6 inherit cvs
7
8 DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
9 HOMEPAGE="http://conky.sf.net"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
14 IUSE="truetype seti X"
15
16 RDEPEND="virtual/libc
17    X? ( virtual/x11 )
18    truetype? ( >=media-libs/freetype-2 )
19    seti? ( sci-astronomy/setiathome )
20    "
21
22 DEPEND="truetype? ( >=media-libs/freetype-2 )
23    X? ( virtual/x11 )
24    >=sys-devel/automake-1.4
25    sys-devel/autoconf
26    sys-apps/grep
27    sys-apps/sed
28    sys-devel/gcc
29    "
30
31 S=${WORKDIR}/conky
32
33 src_unpack() {
34         cvs_src_unpack
35         cd ${S}
36         NOCONFIGURE=blah ./autogen.sh
37 }
38
39 src_compile() {
40    econf \
41       $(use_enable truetype xft) \
42       $(use_enable seti) \
43           $(use_enable X x11) \
44       --enable-double-buffer \
45       --enable-own-window \
46       --enable-proc-uptime \
47           --enable-mpd \
48           --enable-mldonkey \
49       || die "econf failed"
50    emake || die "compile failed"
51 }
52
53 src_install() {
54    emake DESTDIR=${D} install || die "make install failed"
55    dodoc ChangeLog AUTHORS README conkyrc.sample
56 }
57
58 pkg_postinst() {
59    einfo 'default configuration file is "~/.conkyrc"'
60    einfo "you can find a sample configuration file in"
61    einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
62    einfo
63    einfo "For more info on Conky's new features,"
64    einfo "please look at the README and ChangeLog:"
65    einfo "/usr/share/doc/${PF}/README.gz"
66    einfo "/usr/share/doc/${PF}/ChangeLog.gz"
67    einfo
68    einfo "Comment out temperature info lines if you have no kernel"
69    einfo "support for it."
70    einfo
71    ewarn "Conky doesn't work with window managers that"
72    ewarn "take control over root window such as Gnome's nautilus."
73