stuff
[monky] / app-admin / conky / conky-1.9999.ebuild
1 # CVS ebuild for Conky, thanks to Hopeless
2 # $Header$
3
4 ECVS_SERVER="cvs.sourceforge.net:/cvsroot/conky"
5 ECVS_MODULE="conky"
6 inherit cvs
7
8 DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
9 HOMEPAGE="http://conky.sf.net"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
14 IUSE="truetype seti metar X"
15
16 RDEPEND="virtual/libc
17    X? ( virtual/x11 )
18    truetype? ( >=media-libs/freetype-2 )
19    seti? ( sci-astronomy/setiathome )
20    metar? ( dev-libs/mdsplib )
21    "
22
23 DEPEND="truetype? ( >=media-libs/freetype-2 )
24    metar? ( dev-libs/mdsplib )
25    X? ( virtual/x11 )
26    >=sys-devel/automake-1.4
27    sys-devel/autoconf
28    sys-apps/grep
29    sys-apps/sed
30    sys-devel/gcc
31    "
32
33 S=${WORKDIR}/conky
34
35 src_unpack() {
36         cvs_src_unpack
37         cd ${S}
38         NOCONFIGURE=blah ./autogen.sh
39 }
40
41 src_compile() {
42    econf \
43       $(use_enable truetype xft) \
44       $(use_enable metar) \
45       $(use_enable seti) \
46           $(use_enable x x11) \
47       --enable-double-buffer \
48       --enable-own-window \
49       --enable-proc-uptime \
50           --enable-mpd \
51           --enable-mldonkey \
52       || die "econf failed"
53    emake || die "compile failed"
54 }
55
56 src_install() {
57    emake DESTDIR=${D} install || die "make install failed"
58    dodoc ChangeLog AUTHORS README conkyrc.sample
59 }
60
61 pkg_postinst() {
62    einfo 'default configuration file is "~/.conkyrc"'
63    einfo "you can find a sample configuration file in"
64    einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
65    einfo
66    einfo "For more info on Conky's new features,"
67    einfo "please look at the README and ChangeLog:"
68    einfo "/usr/share/doc/${PF}/README.gz"
69    einfo "/usr/share/doc/${PF}/ChangeLog.gz"
70    einfo
71    einfo "Comment out temperature info lines if you have no kernel"
72    einfo "support for it."
73    einfo
74    ewarn "Conky doesn't work with window managers that"
75    ewarn "take control over root window such as Gnome's nautilus."
76