259ad6e752e0a55cc00ed773e48d13abc154cb79
[monky] / app-admin / conky / conky-1.9999.ebuild
1 # CVS ebuild for Conky, thanks to Hopeless
2 # $Header$
3
4 ECVS_SERVER="cvs.sourceforge.net:/cvsroot/conky"
5 ECVS_MODULE="conky"
6 inherit cvs
7
8 DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
9 HOMEPAGE="http://conky.sf.net"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
14 IUSE="truetype seti X"
15
16 RDEPEND="virtual/libc
17    X? ( virtual/x11 )
18    truetype? ( >=media-libs/freetype-2 )
19    seti? ( sci-astronomy/setiathome )
20    "
21
22 DEPEND="truetype? ( >=media-libs/freetype-2 )
23    X? ( virtual/x11 )
24    >=sys-devel/automake-1.9
25    >=sys-devel/autoconf-2.59
26    sys-devel/libtool
27    sys-apps/grep
28    sys-apps/sed
29    sys-devel/gcc
30    "
31
32 S=${WORKDIR}/conky
33
34 src_unpack() {
35         cvs_src_unpack
36         cd ${S}
37         NOCONFIGURE=blah ./autogen.sh
38 }
39
40 src_compile() {
41     local myconf
42     myconf="--enable-double-buffer --enable-own-window --enable-proc-uptime --enable-mpd --enable-mldonkey"
43     econf \
44         ${myconf} \
45         $(use_enable truetype xft) \
46         $(use_enable X x11) \
47         $(use_enable !ipv6 portmon) \
48         $(use_enable seti) || die "econf failed"
49     emake || die "compile failed"
50 }
51
52 src_install() {
53    emake DESTDIR=${D} install || die "make install failed"
54    dodoc ChangeLog AUTHORS README doc/conkyrc.sample
55 }
56
57 pkg_postinst() {
58    einfo 'default configuration file is "~/.conkyrc"'
59    einfo "you can find a sample configuration file in"
60    einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
61    einfo
62    einfo "For more info on Conky's new features,"
63    einfo "please look at the README and ChangeLog:"
64    einfo "/usr/share/doc/${PF}/README.gz"
65    einfo "/usr/share/doc/${PF}/ChangeLog.gz"
66    einfo
67    einfo "Comment out temperature info lines if you have no kernel"
68    einfo "support for it."
69    einfo
70    ewarn "Conky doesn't work with window managers that"
71    ewarn "take control over root window such as Gnome's nautilus."
72