disable X11 with use flag -X as per Gentoo bug #166500
[monky] / app-admin / conky / conky-1.999.ebuild
1 # Subversion repository ebuild for conky by drphibes
2 # $Header: $
3
4 ESVN_REPO_URI="https://conky.svn.sourceforge.net/svnroot/conky/trunk/conky1"
5 ESVN_PROJECT="conky1"
6 inherit subversion
7
8 DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
9 HOMEPAGE="http://conky.sf.net"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
14 IUSE="truetype X ipv6 audacious bmpx hddtemp mpd network vim-syntax"
15
16 DEPEND_COMMON="
17         virtual/libc
18         X? (
19                 || ( ( x11-libs/libICE
20                                 x11-libs/libXext
21                                 x11-libs/libX11
22                                 x11-libs/libSM
23                                 x11-libs/libXrender
24                                 x11-libs/libXdamage
25                                 x11-libs/libXft
26                                 )
27                                 virtual/x11
28                 )
29                 truetype? ( >=media-libs/freetype-2 )
30                 audacious? ( >=media-sound/audacious-0.1 )
31                 bmpx? ( media-sound/bmpx
32                                 >=sys-apps/dbus-0.35
33                         )
34                 network? ( net-libs/libdexter
35                                         net-libs/dxt-plugins-sysinfo
36                                 )
37                 !ipv6? ( >=dev-libs/glib-2.0 )
38         )"
39
40 RDEPEND="${DEPEND_COMMON}
41         hddtemp? ( app-admin/hddtemp )
42         mpd? ( media-sound/mpd )
43         vim-syntax? ( || ( app-editors/vim
44                 app-editors/gvim ) )"
45
46 DEPEND="
47         ${DEPEND_COMMON}
48         X? (
49                 || ( ( x11-libs/libXt
50                                 x11-proto/xextproto
51                                 x11-proto/xproto
52                                 )
53                                 virtual/x11
54                 )
55         )"
56
57 S=${WORKDIR}/conky
58
59 src_compile() {
60         ./autogen.sh ${ESVN_STORE_DIR}/${ESVN_PROJECT}/conky1
61
62         local mymake
63         if useq ipv6 ; then
64                 ewarn
65                 ewarn "You have the ipv6 USE flag enabled.  Please note that using"
66                 ewarn "the ipv6 USE flag with Conky disables the port monitor."
67                 epause
68         else
69                 mymake="MPD_NO_IPV6=noipv6"
70         fi
71         local myconf
72         myconf="--enable-proc-uptime"
73         if useq X; then
74                 myconf="${myconf} --enable-x11 --enable-double-buffer --enable-xdamage --enable-own-window"
75                 myconf="${myconf} $(use_enable truetype xft)"
76         else
77                 myconf="${myconf} --disable-x11 --disable-double-buffer --disable-xdamage --disable-own-window"
78                 myconf="${myconf} --disable-xft"
79         fi
80         econf \
81                 ${myconf} \
82                 $(use_enable audacious) \
83                 $(use_enable bmpx) \
84                 $(use_enable hddtemp ) \
85                 $(use_enable network ) \
86                 $(use_enable mpd) \
87                 $(use_enable !ipv6 portmon) || die "econf failed"
88         emake ${mymake} || die "compile failed"
89 }
90
91 src_install() {
92         emake DESTDIR="${D}" install || die "make install failed"
93         dodoc ChangeLog AUTHORS README doc/conkyrc.sample
94         dohtml doc/docs.html doc/config_settings.html doc/variables.html
95
96         if use vim-syntax; then
97                 insinto /usr/share/vim/vimfiles/ftdetect
98                 doins "${S}"/extras/vim/ftdetect/conkyrc.vim
99
100                 insinto /usr/share/vim/vimfiles/syntax
101                 doins "${S}"/extras/vim/syntax/conkyrc.vim
102         fi
103 }
104
105 pkg_postinst() {
106         einfo 'Default configuration file is "~/.conkyrc"'
107         einfo "You can find a sample configuration file in"
108         einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
109         einfo
110         einfo "For more info on Conky's new features,"
111         einfo "please look at the README and ChangeLog:"
112         einfo "/usr/share/doc/${PF}/README.gz"
113         einfo "/usr/share/doc/${PF}/ChangeLog.gz"
114         einfo "There are also pretty html docs available"
115         einfo "on Conky's site or in /usr/share/doc/${PF}"
116         einfo
117         einfo "Also see http://www.gentoo.org/doc/en/conky-howto.xml"
118         einfo
119         einfo "Vim syntax highlighting for conkyrc now enabled with"
120         einfo "USE=vim-syntax"
121         einfo
122 }