update svn ebuild to new sourceforge url scheme.
[monky] / app-admin / conky / conky-1.999.ebuild
1 # Subversion repository ebuild for conky by drphibes
2 # $Header: $
3
4 ESVN_REPO_URI="https://conky.svn.sourceforge.net/svnroot/conky/trunk/conky1"
5 ESVN_PROJECT="conky1"
6 inherit subversion
7
8 DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
9 HOMEPAGE="http://conky.sf.net"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
14 IUSE="truetype X ipv6 audacious bmpx hddtemp mpd network vim-syntax"
15
16 DEPEND_COMMON="
17         virtual/libc
18         X? (
19                 || ( ( x11-libs/libICE
20                                 x11-libs/libXext
21                                 x11-libs/libX11
22                                 x11-libs/libSM
23                                 x11-libs/libXrender
24                                 x11-libs/libXdamage
25                                 x11-libs/libXft
26                                 )
27                                 virtual/x11
28                 )
29                 truetype? ( >=media-libs/freetype-2 )
30                 audacious? ( >=media-sound/audacious-0.1 )
31                 bmpx? ( media-sound/bmpx
32                                 >=sys-apps/dbus-0.35
33                         )
34                 network? ( net-libs/libdexter
35                                         net-libs/dxt-plugins-sysinfo
36                                 )
37                 !ipv6? ( >=dev-libs/glib-2.0 )
38         )"
39
40 RDEPEND="${DEPEND_COMMON}
41         hddtemp? ( app-admin/hddtemp )
42         mpd? ( media-sound/mpd )
43         vim-syntax? ( || ( app-editors/vim
44                 app-editors/gvim ) )"
45
46 DEPEND="
47         ${DEPEND_COMMON}
48         X? (
49                 || ( ( x11-libs/libXt
50                                 x11-proto/xextproto
51                                 x11-proto/xproto
52                                 )
53                                 virtual/x11
54                 )
55         )"
56
57 S=${WORKDIR}/conky
58
59 src_compile() {
60         ./autogen.sh ${ESVN_STORE_DIR}/${ESVN_PROJECT}/conky1
61
62         local mymake
63         if useq ipv6 ; then
64                 ewarn
65                 ewarn "You have the ipv6 USE flag enabled.  Please note that using"
66                 ewarn "the ipv6 USE flag with Conky disables the port monitor."
67                 epause
68         else
69                 mymake="MPD_NO_IPV6=noipv6"
70         fi
71         local myconf
72         myconf="--enable-own-window"
73         use X && myconf="${myconf} --enable-x11 --enable-double-buffer --enable-xdamage"
74         econf \
75                 ${myconf} \
76                 $(use_enable truetype xft) \
77                 $(use_enable audacious) \
78                 $(use_enable bmpx) \
79                 $(use_enable hddtemp ) \
80                 $(use_enable network ) \
81                 $(use_enable mpd) \
82                 $(use_enable !ipv6 portmon) || die "econf failed"
83         emake ${mymake} || die "compile failed"
84 }
85
86 src_install() {
87         emake DESTDIR="${D}" install || die "make install failed"
88         dodoc ChangeLog AUTHORS README doc/conkyrc.sample
89         dohtml doc/docs.html doc/config_settings.html doc/variables.html
90
91         if use vim-syntax; then
92                 insinto /usr/share/vim/vimfiles/ftdetect
93                 doins "${S}"/extras/vim/ftdetect/conkyrc.vim
94
95                 insinto /usr/share/vim/vimfiles/syntax
96                 doins "${S}"/extras/vim/syntax/conkyrc.vim
97         fi
98 }
99
100 pkg_postinst() {
101         einfo 'Default configuration file is "~/.conkyrc"'
102         einfo "You can find a sample configuration file in"
103         einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
104         einfo
105         einfo "For more info on Conky's new features,"
106         einfo "please look at the README and ChangeLog:"
107         einfo "/usr/share/doc/${PF}/README.gz"
108         einfo "/usr/share/doc/${PF}/ChangeLog.gz"
109         einfo "There are also pretty html docs available"
110         einfo "on Conky's site or in /usr/share/doc/${PF}"
111         einfo
112         einfo "Also see http://www.gentoo.org/doc/en/conky-howto.xml"
113         einfo
114         einfo "Vim syntax highlighting for conkyrc now enabled with"
115         einfo "USE=vim-syntax"
116         einfo
117 }