5d568e06eec68472dcfcd152b4027439b34c4668
[monky] / app-admin / conky / conky-1.4.3.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header$
4
5 inherit eutils
6
7 DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
8 HOMEPAGE="http://conky.sf.net"
9 SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
14 IUSE="truetype X ipv6 bmpx bmp xmms xmms2 infopipe audacious"
15
16 DEPEND_COMMON="
17         virtual/libc
18         X? (
19                 || ( ( x11-libs/libICE
20                                 x11-libs/libXext
21                                 x11-libs/libX11
22                                 x11-libs/libSM
23                                 x11-libs/libXrender
24                                 x11-libs/libXft
25                                 )
26                                 virtual/x11
27                 )
28                 truetype? ( >=media-libs/freetype-2 )
29                 bmpx? ( media-sound/bmpx
30                                 >=sys-apps/dbus-0.35
31                         )
32                 audacious? ( >=media-sound/audacious-0.1 )
33                 xmms2? ( medis-sound/xmms2 )
34         )"
35
36 RDEPEND="${DEPEND_COMMON}"
37
38 DEPEND="
39         ${DEPEND_COMMON}
40         X? (
41                 || ( ( x11-libs/libXt
42                                 x11-proto/xextproto
43                                 x11-proto/xproto
44                                 )
45                                 virtual/x11
46                 )
47         )
48         sys-apps/grep
49         sys-apps/sed"
50
51 src_compile() {
52         local mymake
53         if useq ipv6 ; then
54                 ewarn
55                 ewarn "You have the ipv6 USE flag enabled.  Please note that"
56                 ewarn "using the ipv6 USE flag with Conky disables the port"
57                 ewarn "monitor."
58                 ewarn
59                 epause
60         else
61                 mymake="MPD_NO_IPV6=noipv6"
62         fi
63         local myconf
64         myconf="--enable-double-buffer --enable-own-window --enable-proc-uptime \
65                 --enable-mpd --enable-mldonkey"
66         econf \
67                 ${myconf} \
68                 $(use_enable truetype xft) \
69                 $(use_enable X x11) \
70                 $(use_enable bmpx) \
71                 $(use_enable xmms2) \
72                 $(use_enable audacious) \
73                 $(use_enable !ipv6 portmon) || die "econf failed"
74         emake ${mymake} || die "compile failed"
75 }
76
77 src_install() {
78         make DESTDIR=${D} install || die "make install failed"
79         dodoc ChangeLog AUTHORS README doc/conkyrc.sample
80         dohtml doc/variables.html doc/docs.html doc/config_settings.html
81 }
82
83 pkg_postinst() {
84         einfo 'Default configuration file is "~/.conkyrc"'
85         einfo "you can find a sample configuration file in"
86         einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
87         einfo
88         einfo "For more info on Conky's new features,"
89         einfo "please look at the README and ChangeLog:"
90         einfo "/usr/share/doc/${PF}/README.gz"
91         einfo "/usr/share/doc/${PF}/ChangeLog.gz"
92         einfo "There are also pretty html docs available"
93         einfo "on Conky's site or in /usr/share/doc/${PF}"
94         einfo
95         einfo "Check out app-vim/conky-syntax for conkyrc"
96         einfo "syntax highlighting in Vim"
97         einfo
98 }