ebuild update
[monky] / app-admin / conky / conky-1.3.2.ebuild
1 inherit eutils
2
3 DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
4 HOMEPAGE="http://conky.sf.net"
5 SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
6
7 LICENSE="BSD"
8 SLOT="0"
9 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
10 IUSE="truetype seti X"
11
12 DEPEND_COMMON="
13         virtual/libc
14         X? (
15                 virtual/x11
16                 truetype? ( >=media-libs/freetype-2 )
17         )"
18
19 RDEPEND="${DEPEND_COMMON}
20         seti? ( sci-astronomy/setiathome )"
21
22 DEPEND="
23         ${DEPEND_COMMON}
24         >=sys-devel/automake-1.9
25         >=sys-devel/autoconf-2.59
26         sys-devel/libtool
27         sys-apps/grep
28         sys-apps/sed
29         sys-devel/gcc"
30
31
32 src_compile() {
33         local myconf
34         myconf="--enable-double-buffer --enable-own-window --enable-proc-uptime
35         --enable-mpd --enable-mldonkey"
36         econf \
37                 ${myconf} \
38                 $(use_enable truetype xft) \
39                 $(use_enable X x11) \
40                 $(use_enable seti) || die "econf failed"
41         emake || die "compile failed"
42 }
43
44 src_install() {
45         emake DESTDIR=${D} install || die "make install failed"
46         dodoc ChangeLog AUTHORS README doc/conkyrc.sample doc/variables.html
47         dodoc doc/docs.html doc/config_settings.html
48 }
49
50 pkg_postinst() {
51         einfo 'Default configuration file is "~/.conkyrc"'
52         einfo "you can find a sample configuration file in"
53         einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
54         einfo
55         einfo "For more info on Conky's new features,"
56         einfo "please look at the README and ChangeLog:"
57         einfo "/usr/share/doc/${PF}/README.gz"
58         einfo "/usr/share/doc/${PF}/ChangeLog.gz"
59         einfo "There are also pretty html docs available"
60         einfo "on Conky's site or in /usr/share/doc/${PF}"
61         einfo
62         einfo "Comment out temperature info lines if you have no kernel"
63         einfo "support for it."
64         einfo
65         ewarn "Conky doesn't work with window managers that"
66         ewarn "take control over root window such as Gnome's nautilus."
67         ewarn
68 }