ebuild update
[monky] / app-admin / conky / conky-1.3.0.ebuild
1 # Copyright 1999-2005 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header$
4
5 inherit eutils
6
7 DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
8 HOMEPAGE="http://conky.sf.net"
9 SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
14 IUSE="truetype seti X"
15
16 DEPEND_COMMON="
17         virtual/libc
18         X? (
19                 virtual/x11
20                 truetype? ( >=media-libs/freetype-2 )
21         )"
22
23 RDEPEND="${DEPEND_COMMON}
24         seti? ( sci-astronomy/setiathome )"
25
26 DEPEND="
27         ${DEPEND_COMMON}
28         >=sys-devel/automake-1.9
29         >=sys-devel/autoconf-2.59
30         sys-devel/libtool
31         sys-apps/grep
32         sys-apps/sed
33         sys-devel/gcc"
34
35
36 src_compile() {
37         local myconf
38         myconf="--enable-double-buffer --enable-own-window --enable-proc-uptime
39         --enable-mpd --enable-mldonkey"
40         econf \
41                 ${myconf} \
42                 $(use_enable truetype xft) \
43                 $(use_enable X x11) \
44                 $(use_enable seti) \
45                 $(use_enable metar) || die "econf failed"
46         emake || die "compile failed"
47 }
48
49 src_install() {
50         emake DESTDIR=${D} install || die "make install failed"
51         dodoc ChangeLog AUTHORS README doc/conkyrc.sample doc/variables.html
52         dodoc doc/docs.html doc/config_settings.html
53 }
54
55 pkg_postinst() {
56         einfo 'Default configuration file is "~/.conkyrc"'
57         einfo "you can find a sample configuration file in"
58         einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
59         einfo
60         einfo "For more info on Conky's new features,"
61         einfo "please look at the README and ChangeLog:"
62         einfo "/usr/share/doc/${PF}/README.gz"
63         einfo "/usr/share/doc/${PF}/ChangeLog.gz"
64         einfo "There are also pretty html docs available"
65         einfo "on Conky's site or in /usr/share/doc/${PF}"
66         einfo
67         einfo "Comment out temperature info lines if you have no kernel"
68         einfo "support for it."
69         einfo
70         ewarn "Conky doesn't work with window managers that"
71         ewarn "take control over root window such as Gnome's nautilus."
72         ewarn
73         ewarn "Please note that METAR support has been removed since 1.2"
74         ewarn
75 }