1.4.0 ebuild
[monky] / app-admin / conky / conky-1.2.ebuild
1 # Copyright 1999-2005 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header$
4
5 inherit eutils
6
7 DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
8 HOMEPAGE="http://conky.sf.net"
9 SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
14 IUSE="truetype seti metar"
15
16 DEPEND_COMMON="
17         virtual/libc
18         virtual/x11
19         truetype? ( >=media-libs/freetype-2 )
20         !amd64? (
21                 !sparc? (
22                         metar? ( dev-libs/mdsplib )
23                 )
24         )"
25
26 #sparc and am64 awaiting keywords as per bug #99262
27
28
29 RDEPEND="${DEPEND_COMMON}
30         seti? ( sci-astronomy/setiathome )"
31
32 DEPEND="
33         ${DEPEND_COMMON}
34         >=sys-devel/automake-1.4
35         sys-devel/autoconf
36         sys-apps/grep
37         sys-apps/sed
38         sys-devel/gcc
39         >=sys-process/procps-3.2.5"
40
41
42 src_compile() {
43         local myconf
44         myconf="--enable-double-buffer --enable-own-window --enable-proc-uptime --enable-mpd --enable-mldonkey"
45         if !use amd64 && !use sparc
46         then
47                 myconf="${myconf} $(use_enable metar)"
48         fi
49         econf \
50                 ${myconf} \
51                 $(use_enable truetype xft) \
52                 $(use_enable seti) \
53                 $(use_enable metar) || die "econf failed"
54         emake || die "compile failed"
55 }
56
57 src_install() {
58         emake DESTDIR=${D} install || die "make install failed"
59         dodoc ChangeLog AUTHORS README conkyrc.sample
60 }
61
62 pkg_postinst() {
63         einfo 'default configuration file is "~/.conkyrc"'
64         einfo "you can find a sample configuration file in"
65         einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
66         einfo
67         einfo "For more info on Conky's new features,"
68         einfo "please look at the README and ChangeLog:"
69         einfo "/usr/share/doc/${PF}/README.gz"
70         einfo "/usr/share/doc/${PF}/ChangeLog.gz"
71         einfo
72         einfo "Comment out temperature info lines if you have no kernel"
73         einfo "support for it."
74         einfo
75         ewarn "Conky doesn't work with window managers that"
76         ewarn "take control over root window such as Gnome's nautilus."
77 }