Maemo debianization.
[wpasupplicant] / debian / patches.debian / 01_use_pkg-config_for_pcsc-lite_module.patch
diff --git a/debian/patches.debian/01_use_pkg-config_for_pcsc-lite_module.patch b/debian/patches.debian/01_use_pkg-config_for_pcsc-lite_module.patch
new file mode 100644 (file)
index 0000000..5964ad9
--- /dev/null
@@ -0,0 +1,17 @@
+From: Reinhard Tartler <siretart@tauware.de>
+References: none
+Description: Use pkg-config for libpcsclite linkage flags
+ At least in debian, we can rely on pkg-config being available and
+ returning more accurate ldflags.
+
+--- a/wpa_supplicant/Makefile
++++ b/wpa_supplicant/Makefile
+@@ -579,7 +579,7 @@ ifdef CONFIG_NATIVE_WINDOWS
+ #dynamic symbol loading that is now used in pcsc_funcs.c
+ #LIBS += -lwinscard
+ else
+-LIBS += -lpcsclite -lpthread
++LIBS += $(shell pkg-config --libs libpcsclite)
+ endif
+ endif