Modifications needed by maemo-launcher.
[speedometer] / debian / rules
index 56f0d35..83d6e5b 100755 (executable)
 
 
 
-CFLAGS = -Wall -g
-
 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-       CFLAGS += -O0
+       CFLAGS += -O0 -g -Wall
 else
-       CFLAGS += -O2
+       CFLAGS += -O2 -g -Wall
 endif
 
 configure: configure-stamp
@@ -91,6 +89,7 @@ binary-arch: build install
 #      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
+       dh_maemolauncher
        dh_gencontrol
        dh_md5sums
        dh_builddeb