Initial import
[samba] / debian / patches / samba.patch
diff --git a/debian/patches/samba.patch b/debian/patches/samba.patch
new file mode 100644 (file)
index 0000000..8578d71
--- /dev/null
@@ -0,0 +1,68 @@
+Index: samba-3.0.21c/source/client/smbmount.c
+===================================================================
+--- samba-3.0.21c.orig/source/client/smbmount.c        2006-02-25 11:57:10.475584681 +0100
++++ samba-3.0.21c/source/client/smbmount.c     2006-02-25 11:58:23.681814024 +0100
+@@ -767,7 +767,7 @@
+                                       *lp = 0;
+                                       pstrcpy(password,lp+1);
+                                       got_pass = True;
+-                                      memset(strchr_m(opteq+1,'%')+1,'X',strlen(password));
++                                      memset(strchr_m(opteq+1,'%')+1,'\0',strlen(password));
+                               }
+                               if ((lp=strchr_m(username,'/'))) {
+                                       *lp = 0;
+@@ -777,7 +777,7 @@
+                                 !strcmp(opts, "password")) {
+                               pstrcpy(password,opteq+1);
+                               got_pass = True;
+-                              memset(opteq+1,'X',strlen(password));
++                              memset(opteq+1,'\0',strlen(password));
+                       } else if(!strcmp(opts, "credentials")) {
+                               pstrcpy(credentials,opteq+1);
+                       } else if(!strcmp(opts, "netbiosname")) {
+@@ -893,7 +893,7 @@
+                       *p = 0;
+                       pstrcpy(password,p+1);
+                       got_pass = True;
+-                      memset(strchr_m(getenv("USER"),'%')+1,'X',strlen(password));
++                      memset(strchr_m(getenv("USER"),'%')+1,'\0',strlen(password));
+               }
+               strupper_m(username);
+       }
+Index: samba-3.0.21c/source/web/diagnose.c
+===================================================================
+--- samba-3.0.21c.orig/source/web/diagnose.c   2006-02-25 11:57:10.476584479 +0100
++++ samba-3.0.21c/source/web/diagnose.c        2006-02-25 11:58:23.683813621 +0100
+@@ -62,6 +62,7 @@
+ {
+       static struct cli_state cli;
++      loopback_ip.s_addr = htonl((127 << 24) + 1);
+       if (!cli_initialise(&cli))
+               return False;
+Index: samba-3.0.21c/source/script/installbin.sh
+===================================================================
+--- samba-3.0.21c.orig/source/script/installbin.sh     2006-02-25 11:57:10.477584277 +0100
++++ samba-3.0.21c/source/script/installbin.sh  2006-02-25 11:58:23.684813419 +0100
+@@ -24,12 +24,14 @@
+  chmod $INSTALLPERMS $BINDIR/$p2
+  # this is a special case, mount needs this in a specific location
+- if [ $p2 = smbmount ]; then
+-   if [ ! -d $DESTDIR/sbin ]; then
+-      mkdir $DESTDIR/sbin
+-   fi 
+-   ln -sf $BINDIR/$p2 $DESTDIR/sbin/mount.smbfs
+- fi
++# Commented out for the Debian Samba package. We take care of this
++# important symlink in debian/rules. (peloy@debian.org)
++# if [ $p2 = smbmount ]; then
++#   if [ ! -d $DESTDIR/sbin ]; then
++#      mkdir $DESTDIR/sbin
++#   fi 
++#   ln -sf $BINDIR/$p2 $DESTDIR/sbin/mount.smbfs
++# fi
+ done