dell another files from this branch - only diags
[findit] / debian / rules
diff --git a/debian/rules b/debian/rules
deleted file mode 100755 (executable)
index 09e56ff..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-PACKAGE=findit
-PYTHON=PYTHONOPTIMIZE=2 python
-
-build:
-       dh_testdir
-
-       # Add here commands to compile the package.
-       mkdir -p $(CURDIR)/po/ru/
-       msgfmt $(CURDIR)/po/ru.po -o $(CURDIR)/po/ru/$(PACKAGE).mo
-       $(PYTHON) setup.py build
-       touch $@
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -rf $(CURDIR)/po/ru
-
-       # Add here commands to clean up after the build process.
-       $(PYTHON) setup.py clean --all
-
-       rm -rf $(CURDIR)/$(PACKAGE).egg-info/
-
-       dh_clean 
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-
-       # Add here commands to install the package into debian/findit
-       $(PYTHON) setup.py install --root $(CURDIR)/debian/$(PACKAGE)
-
-# Build architecture-independent files here.
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_link
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-# Build architecture-dependent files here.
-binary-arch: build install
-
-binary: binary-indep binary-arch
-
-.PHONY: build clean binary-indep binary-arch binary install