Maemo debianization.
[wpasupplicant] / debian / patches.debian / 04_append_mmd_to_default_cflags.patch
diff --git a/debian/patches.debian/04_append_mmd_to_default_cflags.patch b/debian/patches.debian/04_append_mmd_to_default_cflags.patch
new file mode 100644 (file)
index 0000000..f974aeb
--- /dev/null
@@ -0,0 +1,22 @@
+From: Kel Modderman <kel@otaku42.de>
+Reference: http://thread.gmane.org/gmane.linux.drivers.hostap/17265
+Description: Cleanup in the build system.
+ Upstream makes overriding the CFLAGs variable unnecessary hard. This
+ patch make this more straightforward by moving the flag for dependency
+ generation out of the initial definition of the CFLAGS variable. It is
+ appended later then.
+
+--- a/wpa_supplicant/Makefile
++++ b/wpa_supplicant/Makefile
+@@ -3,9 +3,10 @@ CC=gcc
+ endif
+ ifndef CFLAGS
+-CFLAGS = -MMD -O2 -Wall -g
++CFLAGS = -O2 -Wall -g
+ endif
++CFLAGS += -MMD
+ CFLAGS += -I../src
+ CFLAGS += -I../src/crypto
+ CFLAGS += -I../src/utils