Don't really need ebuilds in here anymore.
[monky] / app-admin / conky / conky-1.4.3.ebuild
diff --git a/app-admin/conky/conky-1.4.3.ebuild b/app-admin/conky/conky-1.4.3.ebuild
deleted file mode 100644 (file)
index 02b2a9c..0000000
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils
-
-DESCRIPTION="Conky is an advanced, highly configurable system monitor for X"
-HOMEPAGE="http://conky.sf.net"
-SRC_URI="mirror://sourceforge/conky/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="truetype X ipv6 audacious bmpx hddtemp mpd vim-syntax"
-
-DEPEND_COMMON="
-       virtual/libc
-       X? (
-               || ( ( x11-libs/libICE
-                               x11-libs/libXext
-                               x11-libs/libX11
-                               x11-libs/libSM
-                               x11-libs/libXrender
-                               x11-libs/libXdamage
-                               x11-libs/libXft
-                               )
-                               virtual/x11
-               )
-               truetype? ( >=media-libs/freetype-2 )
-               audacious? ( >=media-sound/audacious-0.1 )
-               bmpx? ( media-sound/bmpx
-                               >=sys-apps/dbus-0.35
-                       )
-       )"
-
-RDEPEND="${DEPEND_COMMON}
-       hddtemp? ( app-admin/hddtemp )
-       mpd? ( media-sound/mpd )"
-
-DEPEND="
-       ${DEPEND_COMMON}
-       X? (
-               || ( ( x11-libs/libXt
-                               x11-proto/xextproto
-                               x11-proto/xproto
-                               )
-                               virtual/x11
-               )
-       )
-       sys-apps/grep
-       sys-apps/sed"
-
-PDEPEND="vim-syntax? ( app-vim/conky-syntax )"
-
-src_compile() {
-       local mymake
-       if useq ipv6 ; then
-               ewarn
-               ewarn "You have the ipv6 USE flag enabled.  Please note that using"
-               ewarn "the ipv6 USE flag with Conky disables the port monitor."
-               epause
-       else
-               mymake="MPD_NO_IPV6=noipv6"
-       fi
-       local myconf
-       myconf="--enable-own-window --enable-proc-uptime"
-       use X && myconf="${myconf} --enable-x11 --enable-double-buffer --enable-xdamage"
-       econf \
-               ${myconf} \
-               $(use_enable truetype xft) \
-               $(use_enable audacious) \
-               $(use_enable bmpx) \
-               $(use_enable hddtemp ) \
-               $(use_enable mpd) \
-               $(use_enable !ipv6 portmon) || die "econf failed"
-       emake ${mymake} || die "compile failed"
-}
-
-src_install() {
-       emake DESTDIR=${D} install || die "make install failed"
-       dodoc ChangeLog AUTHORS README doc/conkyrc.sample
-       dohtml doc/docs.html doc/config_settings.html doc/variables.html
-}
-
-pkg_postinst() {
-       einfo 'Default configuration file is "~/.conkyrc"'
-       einfo "You can find a sample configuration file in"
-       einfo "/usr/share/doc/${PF}/conkyrc.sample.gz"
-       einfo
-       einfo "For more info on Conky's new features,"
-       einfo "please look at the README and ChangeLog:"
-       einfo "/usr/share/doc/${PF}/README.gz"
-       einfo "/usr/share/doc/${PF}/ChangeLog.gz"
-       einfo "There are also pretty html docs available"
-       einfo "on Conky's site or in /usr/share/doc/${PF}"
-       einfo
-       einfo "Also see http://www.gentoo.org/doc/en/conky-howto.xml"
-       einfo
-       einfo "Check out app-vim/conky-syntax for conkyrc"
-       einfo "syntax highlighting in Vim"
-       einfo
-}