New version, including standard dbus service and building smoothly also under debian...
[wifihood] / wifiscand / debian / rules
index 4d72a01..15ce999 100755 (executable)
@@ -34,7 +34,12 @@ build-stamp: configure-stamp
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE) wifiscand CPPFLAGS="-DHAVE_LIBOSSO"
+       pkg-config --exists libosso ; \
+               if [ $? -eq 0 ] ; then \
+               echo $(MAKE) wifiscand CPPFLAGS="-DHAVE_LIBOSSO" ; \
+               else \
+               echo $(MAKE) wifiscand ; \
+               fi
 
        touch build-stamp