Add MCE plugin.
[tweakr] / modules / Makefile.am
index 4f2afb1..216dc90 100644 (file)
@@ -5,11 +5,14 @@ AM_CPPFLAGS = \
        -I$(top_srcdir) \
        $(GTK_CFLAGS)   \
        $(HILDON_CFLAGS)        \
-       -DTRANSITIONS=\"/usr/share/hildon-desktop/transitions.ini\"
+       -DTRANSITIONS=\"/usr/share/hildon-desktop/transitions.ini\"     \
+       -DMCE=\"/etc/mce/mce.ini\"
 
 modulesdir = $(libdir)/maemo-tweaks/modules
 
-modules_LTLIBRARIES = libmaemo-tweaks-desktop.la
+modules_LTLIBRARIES = \
+       libmaemo-tweaks-desktop.la \
+       libmaemo-tweaks-mce.la
 
 libmaemo_tweaks_desktop_la_SOURCES = maemo-tweaks-desktop.c
 libmaemo_tweaks_desktop_la_LDFLAGS = -avoid-version -module
@@ -18,8 +21,22 @@ libmaemo_tweaks_desktop_la_LIBADD = \
        $(GTK_LIBS)     \
        $(HILDON_LIBS)
 
-bin_PROGRAMS = maemo-tweaks-desktop-save
+libmaemo_tweaks_mce_la_SOURCES = maemo-tweaks-mce.c
+libmaemo_tweaks_mce_la_LDFLAGS = -avoid-version -module
+libmaemo_tweaks_mce_la_LIBADD = \
+       $(libmaemo_tweaks_section)      \
+       $(GTK_LIBS)     \
+       $(HILDON_LIBS)
+
+bin_PROGRAMS = \
+       maemo-tweaks-desktop-save       \
+       maemo-tweaks-mce-save
+
 maemo_tweaks_desktop_save_SOURCES = maemo-tweaks-desktop-save.c
 maemo_tweaks_desktop_save_LDADD = \
        $(GLIB_LIBS)
 
+maemo_tweaks_mce_save_SOURCES = maemo-tweaks-mce-save.c
+maemo_tweaks_mce_save_LDADD = \
+       $(GLIB_LIBS)
+