Added maemo-cflags-cdbs-rules as dependency
[maemo-efl] / trunk / evas / debian / rules
index 4df0660..74c218f 100755 (executable)
@@ -2,22 +2,22 @@
 
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
-include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/maemo-cflags.mk
 
+DEB_CONFIGURE_SCRIPT := ./autogen.sh
 DEB_CONFIGURE_EXTRA_FLAGS := --enable-software-16-x11                  \
-                                                        --enable-software-x11                          \
-                                                        --disable-scale-smooth                         \
-                                                        --disable-pthreads                                     \
-                                                        --enable-no-dither-mask                        \
-                                                        --enable-small-dither-mask                     \
-                                                        --disable-fb                                           \
-                                                        --disable-xrender-x11                          \
+                                                        --enable-software-x11                  \
+                                                        --disable-scale-smooth                 \
+                                                        --disable-pthreads                     \
+                                                        --enable-no-dither-mask                \
+                                                        --enable-small-dither-mask             \
+                                                        --disable-fb                           \
+                                                        --disable-xrender-x11                  \
                                                         --disable-image-loader-tiff            \
-                                                        --disable-image-loader-edb                     \
-                                                        --disable-image-loader-gif                     \
-                                                        --disable-image-loader-xpm                     \
-                                                        --disable-image-loader-svg                     \
-                                                        --disable-convert-yuv                          \
+                                                        --disable-image-loader-edb             \
+                                                        --disable-image-loader-xpm             \
+                                                        --disable-image-loader-svg             \
+                                                        --disable-convert-yuv                  \
                                                         --disable-convert-8-rgb-332            \
                                                         --disable-convert-8-rgb-666            \
                                                         --disable-convert-8-rgb-232            \
@@ -41,18 +41,4 @@ DEB_CONFIGURE_EXTRA_FLAGS := --enable-software-16-x11                        \
                                                         --disable-convert-32-rgb-rot-90        \
                                                         --disable-sdl
 
-
-DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-
-CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2
-
-ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
-       ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
-               CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
-       endif
-       ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
-               CFLAGS += -mcpu=arm926ej-s
-       endif
-endif
-
-
+CFLAGS+=-I/usr/X11R6/include