Added specific build options depending on the target device
[maemo-efl] / trunk / evas / debian / rules
index 3062506..3fdf303 100755 (executable)
@@ -44,10 +44,8 @@ DEB_CONFIGURE_EXTRA_FLAGS := --enable-software-16-x11                        \
 
 DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
 
-CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2
-
 ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
-       CFLAGS += -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
+       CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
        ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
                CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
        endif