Added maemo-cflags-cdbs-rules as dependency
[maemo-efl] / trunk / etk / debian / rules
index 4e987df..c323caf 100755 (executable)
@@ -3,18 +3,7 @@
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
 include /usr/share/cdbs/1/rules/simple-patchsys.mk
+include /usr/share/cdbs/1/rules/maemo-cflags.mk
 
+DEB_CONFIGURE_SCRIPT := ./autogen.sh
 DEB_CONFIGURE_EXTRA_FLAGS := --disable-ecore-fb-x11-support
-
-DEB_BUILD_ARCH  ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-
-ifneq (,$(findstring armel,$(DEB_BUILD_ARCH)))
-       CFLAGS += -DNDEBUG=1 -fomit-frame-pointer -O2 -ffast-math -funsafe-math-optimizations -fno-math-errno -fsingle-precision-constant
-       ifneq (,$(findstring n8x0,$(DEB_BUILD_OPTIONS)))
-               CFLAGS += -mfpu=vfp -mfloat-abi=softfp -mcpu=arm1136jf-s
-       endif
-       ifneq (,$(findstring n770,$(DEB_BUILD_OPTIONS)))
-               CFLAGS += -mcpu=arm926ej-s
-       endif
-endif
-