Generate and save uImage during compile process
[kernel-bfs] / kernel-bfs-2.6.28 / debian / rules
index 9cf84ae..7dcd7d9 100644 (file)
@@ -58,6 +58,8 @@ configure-stamp:
 
 kernel-stamp: configure-stamp
        echo "compile $(PRODUCT) kernel"
+       mkimage  -A arm -O linux -T kernel -C none -a 80008000 -e 80008000 -n kernel-bfs -d $(BUILDTMP)/arch/arm/boot/zImage $(BUILDTMP)/arch/arm/boot/uImage
+       cp $(BUILDTMP)/arch/arm/boot/uImage ../uImage
        cd $(KSRC) && $(MAKE) $(NJOBS) $(EXTRAVERSION) zImage
        touch $@