Updated packaging files in debian folder.
[ptas] / zouba / debian / rules
index f8b4404..f90a2da 100755 (executable)
@@ -9,37 +9,31 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+APPNAME := zouba
+builddir:
+       mkdir -p builddir
 
-
-
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       qmake
-       touch configure-stamp
+builddir/Makefile: builddir
+       cd builddir && qmake-qt4 PREFIX=/usr ../$(APPNAME).pro
 
 
 build: build-stamp
 
-build-stamp: configure-stamp  
+build-stamp: builddir/Makefile
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE)
-       #docbook-to-man debian/zouba.sgml > zouba.1
+       cd builddir && $(MAKE)
 
        touch $@
 
 clean: 
        dh_testdir
        dh_testroot
-       rm -f build-stamp configure-stamp
+       rm -f build-stamp
 
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
+       rm -rf builddir
 
        dh_clean 
 
@@ -50,7 +44,7 @@ install: build
        dh_installdirs
 
        # Add here commands to install the package into debian/zouba.
-       $(MAKE) INSTALL_ROOT="$(CURDIR)"/debian/zouba install
+       cd builddir && $(MAKE) INSTALL_ROOT=$(CURDIR)/debian/$(APPNAME) install
 
 
 # Build architecture-independent files here.
@@ -61,12 +55,12 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
+#      dh_installchangelogs 
        dh_installdocs
        dh_installexamples
 #      dh_install
 #      dh_installmenu
-#      dh_installdebconf       
+#      dh_installdebconf
 #      dh_installlogrotate
 #      dh_installemacsen
 #      dh_installpam
@@ -77,7 +71,7 @@ binary-arch: build install
 #      dh_installinfo
        dh_installman
        dh_link
-       dh_strip
+#      dh_strip
        dh_compress
        dh_fixperms
 #      dh_perl